Bug 131310 - videos inserted in Impress slides don't render in slide show in GDI in some Windows (OK in OpenGL or Skia)
Summary: videos inserted in Impress slides don't render in slide show in GDI in some W...
Status: RESOLVED DUPLICATE of bug 128353
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Media-Playback
  Show dependency treegraph
 
Reported: 2020-03-12 14:05 UTC by Colin Brown
Modified: 2020-10-08 06:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test presentation (3.73 MB, application/vnd.oasis.opendocument.presentation)
2020-10-07 20:21 UTC, Gerhard Weydt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Brown 2020-03-12 14:05:47 UTC
Description:
After upgrading to 6.2.8 to 6.3.5 I found that .avi videos inserted in Impress slides did not render successfully in slide show mode. There was a brief flash of what was probably the first frame, then the display reverted to the slide background image. The problem arose both when the video was linked and when it was embedded in the slide. I discovered this when trying to build a new presentation with 6.3.5 but found the same symptoms when I tried to display an old presentation (several different video clips) made with 6.2.8 which had displayed successfully under 6.2.8. I only tried .avi video, so can't say how other formats behave.

I have now uninstalled 6.3.5 and re-installed 6.2.8. I note that the video in the new presentation I had built with 6.3.5 displays successfuly in 6.2.8, suggesting that this is a rendering problem.

I am running 64 bit Windows 10 Home on a 3 Ghz G3220 Pentium with $GB RAM.


Steps to Reproduce:
1.Insert an avi video in an Impress slide
2.Go to slide show mode to start at the previous slide
3.Advance to the slide containing the video (mouse click)

Actual Results:
The video is not rendered and the slide background image is displayed

Expected Results:
The video should have been rendered


Reproducible: Always


User Profile Reset: No



Additional Info:
Rendered the video
Comment 1 Oliver Grimm 2020-03-22 00:06:09 UTC
cannot confirm here with LO 6.4.1.2 on Linux, VCL kf5, de-de
Comment 2 Gerhard Weydt 2020-04-12 13:23:56 UTC
I can confirm the bug in 6.4.2.2 and 6.3.4.2, in 6.2.3.2 it is still working. I used the same file in all three tests, which was created using 6.3.4.2, so the problem seems not to be raised when the video is inserted.
By the way: the video did run directly after inserting it in 6.3.4.2, but after saving, closing and reopening it didn't work any longer.

All tested with Windows 10, so it might be depending on  gthe operating system.
Comment 3 Gerhard Weydt 2020-04-12 13:37:42 UTC
When right-clicking on the video while the presentation is running and there ending the presentation, the video did run correctly when the presentation was run again, also for the next runs tried.
Comment 4 Timur 2020-10-07 14:28:46 UTC
Bug makes sense only if we have reproducible steps. 
1. Please attach sample ODP. 
2. Try both with/without OpenGL (there up to LO 6.4) or Skia (from 7.0) in Tools-Options-View 
3. Please try daily master from https://dev-builds.libreoffice.org/daily/master/current.html
Comment 5 Gerhard Weydt 2020-10-07 20:20:03 UTC
I think Colin's report describes how to reproduce the problem, but to avoid delay I will add a test presentation Test_avi_does_not_play.odp.
I tested with LibO 6.2.3.2, 6.4.5.2 and 7.0.2.2; I didn't install a daily build because I don't know how to handle that without replacing my working installation, I use Separate Install GUI for a parallel installation, and there the daily builds seem not to be provided.

The results are principally as described, but Timur's guess (?) regarding OpenGL resp. Skia is right:
6.2.3.2: the video plays with and without OpenGL
6.4.5.2: the video plays with OpenGL activated, without it only the sound is playing, the rectangle for the video remains black.
7.0.2.2: same behaviour a 6.4.5.2, if Skia is activated or not instead of OpenGL.

Since OpenGL produced some problems, as I have read many times, many people will have deactivated it. As regards Skia I have no experience and no information, but nevertheless the video should be playing even without Skia, I think.
Comment 6 Gerhard Weydt 2020-10-07 20:21:39 UTC
Created attachment 166171 [details]
test presentation
Comment 7 Timur 2020-10-08 06:29:07 UTC
(In reply to Gerhard Weydt from comment #5)
> I think Colin's report describes how to reproduce the problem, but to avoid
> delay I will add a test presentation Test_avi_does_not_play.odp.
Thanks. Those who test many bugs need clear steps, no time to start from scratch.
More, I tried with avi but it worked, so I wasn't sure if it's about my computer or sample. So, sample is always needed. 

> I use Separate Install GUI for a parallel installation, and
> there the daily builds seem not to be provided.
They are there, daily master like "master x86_64 (TB77-TDF)". I also use it in Windows that way. Mine SI-GUI is 5.0.0.9.

> The results are principally as described, but Timur's guess (?) regarding
> OpenGL resp. Skia is right:
> 6.2.3.2: the video plays with and without OpenGL
> 6.4.5.2: the video plays with OpenGL activated, without it only the sound is
> playing, the rectangle for the video remains black.
> 7.0.2.2: same behaviour a 6.4.5.2, if Skia is activated or not instead of
> OpenGL.
Useful, thanks.

Wrap-up:
Colin didn't write if OpenGL or not/GDI, please test, also test master that installs separately to your working LO, if not using SI-GUI then from https://dev-builds.libreoffice.org/daily/master/current.html.

Gerhard explained well, meaning that on some systems/video cards current LO doesn't play with GDI (plays with OpenGL or Skia). Please test master to be sure.

Timur has no issue with LO 7.0 and master 7.1+ in Windows, video plays with Skia and without (that's GDI). Also no issue in Linux, bug is Windows so far.
Comment 8 Timur 2020-10-08 06:34:46 UTC Comment hidden (obsolete)
Comment 9 Timur 2020-10-08 06:38:35 UTC
This is a regression. Most useful in regression is bibisect. 
But this one can be done only in Windows, and some who do bibisect in Windows do not reproduce it (I do it in Linux for all versions, no more space). 
Meaning: Gerhard, you seem to be advanced Lo contributor, please see if you could set up Windows bibisect as in https://wiki.documentfoundation.org/QA/Bibisect.
Comment 10 Timur 2020-10-08 06:40:50 UTC
Oliver, pleas test and write your video card... and see me praising Win bibisecters :)
Comment 11 Timur 2020-10-08 06:52:06 UTC
(In reply to Timur from comment #8)
> This may be a duplicate of
> https://bugs.documentfoundation.org/show_bug.cgi?id=130524. Please write
> your video cards.

Actually, this 131310 and bug 130524 look duplicates of Bug 128353 which is already bibisected.

*** This bug has been marked as a duplicate of bug 128353 ***