Download it now!
Bug 131324 - Editing cross reference field does not pre-select current mode
Summary: Editing cross reference field does not pre-select current mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2020-03-13 08:03 UTC by Mike Kaganski
Modified: 2020-03-19 13:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A sample cross reference field (8.92 KB, application/vnd.oasis.opendocument.text)
2020-03-13 08:03 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-03-13 08:03:12 UTC
Created attachment 158664 [details]
A sample cross reference field

Steps: in the attachment, right-click on the "Figure 1" field in "See Figure 1" line, and select "Edit Fields...". See that "Insert reference to" box has "Page" selected, while actual mode is "Category and Number".

OK in Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 12; OS: Windows 10.0; UI render: GL; 
Locale: ru-RU (ru_RU); Calc: group threaded

Bad in Version: 6.4.2.1 (x64)
Build ID: c92dba0b4728c0ec26c4b83e2c0fbf3284425375
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Comment 1 Dieter 2020-03-13 17:49:50 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: c63148ba139bd6b9ae7a0f9e24e51f29e5370963
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 2 raal 2020-03-13 20:38:38 UTC
cannot confirm with Version: 7.0.0.0.alpha0+
Build ID: a11c10a83f6fceae6cfb519725d06f8eaf1013fb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 3 Xisco Faulí 2020-03-17 11:36:26 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: 4ee7ee1c4a515479bc174543af4dbc400035c0ba
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Dieter 2020-03-17 11:38:10 UTC
Is it possible, that it is only Windows?
Comment 5 Xisco Faulí 2020-03-17 11:47:35 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 59b755eb93136ea28916e875ee28a50ac7c12fb5
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2020-03-17 12:24:30 UTC
Not reproducible in

Version: 7.0.0.0.alpha0+ (x64)
Build ID: ec85ed21a960a198a01778cdb89a91fabcb5d0c0
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

either
Comment 7 Xisco Faulí 2020-03-19 13:13:08 UTC
Not reproducible in

Version: 7.0.0.0.alpha0+ (x64)
Build ID: bc898e2c2784e36ad4d4cdf6d962e39069d2c82d
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 8 Mike Kaganski 2020-03-19 13:20:07 UTC
Yes, WORKSFORME. Thanks!
Comment 9 Mike Kaganski 2020-03-19 13:21:32 UTC
But is it fixed in upcomung 6.4.3? (it is still broken in 6.4.2.2)