Bug 131384 - FILESAVE Tabbed view erases conditional format on xlsx files when saving
Summary: FILESAVE Tabbed view erases conditional format on xlsx files when saving
Status: RESOLVED DUPLICATE of bug 130108
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2020-03-17 00:08 UTC by 24-7
Modified: 2020-12-17 14:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample xlsx file (42.01 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-03-17 21:41 UTC, 24-7
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 24-7 2020-03-17 00:08:05 UTC
Description:
Open an xlsx file that was previously saved on Microsoft Office (if it was saved on LibreOffice it doesn't reproduce), change the interface to tabbed view, save and then close the file. The next time you open the file, conditions for conditional format remain, but the conditional styles have been removed so not applied.

Steps to Reproduce:
1.Open any xlsx file previously saved on Microsoft Office, not LibreOffice
2.Change interface to tabbed view
3.Save file
4.Open file again

Actual Results:
Conditional styles are erased from the document

Expected Results:
Conditional styles should remain and conditional formatting applied


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Linux 5.5; UI render: default; VCL: gtk3; 
Locale: es-MX (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 m.a.riosv 2020-03-17 21:12:05 UTC
Please can you attach the sample file?
Comment 2 24-7 2020-03-17 21:41:59 UTC
Created attachment 158767 [details]
Sample xlsx file

Hi, of course.

Actually it happens to any file, you just have to create it in MO and then open in LO with tabbed view and save; if you save not beign in tabbed view and then change to tabbed view, it doesn't occur.

Sending one sample file.

Thanks!
Comment 3 24-7 2020-03-17 21:42:26 UTC Comment hidden (obsolete)
Comment 4 24-7 2020-03-17 21:43:07 UTC Comment hidden (obsolete)
Comment 5 m.a.riosv 2020-03-18 07:58:27 UTC
Why do you think everybody has MO?

Confirmed.
Version: 6.4.2.2 (x64)
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS: Windows 10.0 Build 19582; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL

In same way the styles used by the CF are changed to default.
Comment 6 Roman Kuznetsov 2020-05-05 09:07:27 UTC
I couldn't repro it in

Version: 7.0.0.0.alpha0+
Build ID: da21c6756571037dd2e5956a5aa56615f8f29be7
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Can you people retest it in master build?
Comment 7 m.a.riosv 2020-05-05 09:41:36 UTC
Seems works fine now with:
Version: 6.4.4.1 (x64)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 4; OS: Windows 10.0 Build 19608; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 8 Roman Kuznetsov 2020-05-05 13:28:08 UTC
24-7@live.com.mx please update your LibreOffice to 6.4.3 (or 6.4.4.1 from https://dev-builds.libreoffice.org/pre-releases/) and try retest your problem
Comment 9 24-7 2020-05-05 18:09:06 UTC
Hi. I updated and still reproducible by following the steps listed at the beginning.
Comment 10 QA Administrators 2020-05-06 03:45:33 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2020-08-27 15:57:40 UTC
No problem here with tabbed

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: e2fe4fde592564d35099ad1e2659ad682dfb77f5
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 25 August 2020
Comment 12 NISZ LibreOffice Team 2020-12-17 14:14:12 UTC
bibisect-7.0 repo shows this is gone since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=454a3c945fdc02d706b0a5ad49ca13e0443fa8e5

author	Caolán McNamara <caolanm@redhat.com>	2020-05-03 16:43:06 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-05-03 20:07:48 +0200

Resolves: tdf#130108 ensure we don't reuse the last SetSearchMask setting

*** This bug has been marked as a duplicate of bug 130108 ***