Download it now!
Bug 131400 - Hyperlink text is not word wraped, nor hyphenated.
Summary: Hyperlink text is not word wraped, nor hyphenated.
Status: RESOLVED DUPLICATE of bug 40563
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-18 10:19 UTC by Sebastian
Modified: 2020-06-19 03:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Demo file with hyperlink in impress (20.27 KB, application/vnd.oasis.opendocument.presentation)
2020-03-18 10:49 UTC, Sebastian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian 2020-03-18 10:19:14 UTC
Description:
Hyphenation and word wrapping does not work hyperlink text.

Steps to Reproduce:
1.Input some long text which word wraps in a frame or at the edge of page and activate hyphenation Tools > Language> Hyphenation
2. Make this text are hyperlink pointing to somewhere
3.Now the hyphenation does not work on the text which is now hyperlink.

Actual Results:
Immediately after making text hyperlink it does not word wrap in a frame but it is displayed in a single line which goes out of boundry of the frame on its right end. When I click the frame the hyperlinks text wraps again in frame but words are divided by one letter just to fit in frame or page. So word wraping and hyphenation does not work for hyperlink now and words are divided whatever just to fit in frame. 

Expected Results:
Immediately after making text hyperlink, hyperlink text should stay in the boundries of a frame or page and word wrap in boundries of frame or page and stay correctly hyphened according to hyphenation dictionary rules if the hyphenation is enabled for it.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Wersion: 6.3.5.2 (x64)
Compilation indentifier: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 8; Operating system: Windows 10.0; Render UI: GL; VCL: win; 
Ustawienia regionalne: pl-PL (pl_PL); Język UI: pl-PL
Calc: CL

Windows 10 build 18363.720 on linux, Ubuntu 1804.04 LTS this happens too. LO ver 6.0.7.3 is on latest version on updates 18.04 LTS.
Comment 1 Sebastian 2020-03-18 10:21:50 UTC
This bug also breaks word wrapping and hyphenation on hyperlink text.
Comment 2 Sebastian 2020-03-18 10:49:58 UTC
Created attachment 158780 [details]
Demo file with hyperlink in impress

Formating, word wrapping, hyphenation does not work for hyperlink text.
Comment 3 Sebastian 2020-03-18 10:52:30 UTC
This might be duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=40563
Comment 4 Buovjaga 2020-06-18 18:41:05 UTC
(In reply to Sebastian from comment #3)
> This might be duplicate of
> https://bugs.documentfoundation.org/show_bug.cgi?id=40563

Indeed, let's close

*** This bug has been marked as a duplicate of bug 40563 ***