Bug 131463 - Some Slide Transition Does Not Work As Expected
Summary: Some Slide Transition Does Not Work As Expected
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-21 12:50 UTC by Rizal Muttaqin
Modified: 2021-01-17 06:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Wrong Slide Transition (2.56 MB, video/mp4)
2020-03-21 23:11 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2020-03-21 12:50:20 UTC
Some of Slide Transitions does not work as expected, IIRC this issue appears in 6.x series but which exact version it started to arise

1. Fade > not sure this works or not 
2. Cut
3. Push > looks like inverted, the image similar with wipe but out of white rectangular border
4. Fall
5. Vortex 
6. Honeycomb

Talking about slide transition, why LibreOffice has less slide transition effects than OpenOffice 4.1.7 AOO417m1(Build:9800) - Rev.46059c9192 (34 vs 65 effects)?

LibreOffice: 
Version: 7.0.0.0.alpha0+
Build ID: 17e712ccc8fa93d57672916e3c8adaa8febc9f8c
CPU threads: 4; OS: Linux 4.20; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-03-13_16:53:06
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Oliver Grimm 2020-03-21 22:51:52 UTC
This bug report contains multiple issues. Please pick one of them and provide a step-by-step description of how to reproduce it, including your expected outcome.

A screenshot or small video might be useful, too, for us to understand this topic.

Please change the bug title to the chosen issue so we can keep track of it specifically.

I am setting this to NEEDINFO for now. Please feel free to set this bug back to UNCONFIRMED once you have provided the requested details.
Comment 2 Rizal Muttaqin 2020-03-21 23:11:03 UTC
Created attachment 158859 [details]
Wrong Slide Transition

As you can see in the video, I don't think I talk about multiple issues, here we discussed Slide Transition per se.
Comment 3 QA Administrators 2020-03-22 02:40:31 UTC Comment hidden (obsolete)
Comment 4 Timur 2020-03-22 14:25:47 UTC Comment hidden (obsolete)
Comment 5 Timur 2020-03-22 14:28:19 UTC Comment hidden (obsolete)
Comment 6 Rizal Muttaqin 2020-03-22 15:37:17 UTC
(In reply to Timur from comment #4)
> I didn't test but looks like a duplicate of
> https://bugs.documentfoundation.org/show_bug.cgi?id=91456#c19. 
> Please see and mark. That one should be High importance. 
> That bug refers to a single transition, but even that is not fixed in years.

You can open my video attached here to see the detail.

https://bugs.documentfoundation.org/show_bug.cgi?id=91456#c19 obviously was different topic, he/she talked about a fraction of previous slide and I don't see the issue now in the daily master build (Version: 7.0.0.0.alpha0+
Build ID: 17e712ccc8fa93d57672916e3c8adaa8febc9f8c) nor in the fresh version ( 6.4.1.2). I'm talking about different appearance of the selected Slide Transition effect and the applied one. For example the HONEYCOMB transition just show WIPE RIGHT transition while FALL transition show nothing.
Comment 7 Rizal Muttaqin 2020-03-22 15:38:03 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2020-03-23 02:59:32 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2020-05-17 18:19:33 UTC
I think this has to do with the OpenGL support of your hardware on Linux. The only non-working one for me is Fall.

Arch Linux 64-bit
Version: 6.4.3.2
Build ID: 6.4.3-1
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Comment 10 Xisco Faulí 2020-06-17 11:03:45 UTC
Hello Rizal,
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 11 QA Administrators 2020-12-15 03:46:35 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2021-01-15 04:25:32 UTC Comment hidden (obsolete)
Comment 13 Rizal Muttaqin 2021-01-17 06:55:16 UTC
In latest master version, Vortex and Honeycomb are only two slide transitions which is now working. Other are still in same state.

1. Fade > not sure this works or not 
2. Cut
3. Push > looks like inverted, the image similar with wipe but out of white rectangular border
4. Fall


Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 56f26399df894d05f24874a3cdc90694158e03bc
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: id-ID (id_ID.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-01-16_03:41:06
Calc: threaded