Download it now!
Bug 131511 - FILESAVE DOC(X): "Evenly distribute contents to all columns" not saved when turned off
Summary: FILESAVE DOC(X): "Evenly distribute contents to all columns" not saved when...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
: 131466 (view as bug list)
Depends on:
Blocks: DOC Page-Layout-Columns DOCX-Section
  Show dependency treegraph
 
Reported: 2020-03-23 22:07 UTC by Bart
Modified: 2020-03-28 11:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
This is the document with the two columns that I'm trying to change (45.00 KB, application/msword)
2020-03-23 22:08 UTC, Bart
Details
Checking/unchecking Equal Column width in Word version 14.0 (117.56 KB, image/png)
2020-03-25 15:22 UTC, Bart
Details
The document after changing "Equal Columns" in Word (44.50 KB, application/msword)
2020-03-25 15:23 UTC, Bart
Details
A document created with Word 14 that shows uneven columns (26.50 KB, application/msword)
2020-03-26 03:04 UTC, Bart
Details
A document created with Word 14 that shows uneven columns (screen copy) (106.18 KB, image/png)
2020-03-26 03:05 UTC, Bart
Details
A document created with Word 14 that shows even columns (26.50 KB, application/msword)
2020-03-26 03:06 UTC, Bart
Details
A document created with Word 14 that shows even columns (screen copy) (89.47 KB, image/png)
2020-03-26 03:07 UTC, Bart
Details
A document created with Word 14, changing the last lines into one column (125.42 KB, image/png)
2020-03-26 03:10 UTC, Bart
Details
LONoOptionEvenlyDistribute.png : The option "Evenly distribute columns" is absent (225.78 KB, image/png)
2020-03-26 11:24 UTC, Bart
Details
LOWithOptionEvenlyDistribute.png : The option "Evenly distribute columns" is present (191.03 KB, image/png)
2020-03-26 11:25 UTC, Bart
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bart 2020-03-23 22:07:42 UTC
Description:
When choosing not to distribute the text over two columns, that change is correctly reflected in the document just after that choice has been made. 

However, when saving the document, closing it and reopening it, the text on the last page is again evenly distributed over two columns. 

I wonder if this setting is not saved in the document when I when I saved the document, closed it and reopened it.

Steps to Reproduce:
1. Open document "The Actor At Work - Lesson Twenty LO.doc"
2. Go to the last page and click inside one of the columns
3. Choose "Format -> Columns"
4. Uncheck "Evenly distribute contents to all columns" and click OK
5. Save the document as "Word 97-2003 (.doc)" and close it.
6. Open the document again and check the columns of the last page

Actual Results:
After the last step, the text is again evenly distributed over both columns.

Expected Results:
After the last step, I had expected the text to be in the left column only.


Reproducible: Always


User Profile Reset: No



Additional Info:
I also opened this document with Microsoft Word, made this change and saved the document. When reopening this document with Libre Office Writer, the text on the last page now appears nicely in the left column only. 

Version: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Bart 2020-03-23 22:08:54 UTC
Created attachment 158907 [details]
This is the document with the two columns that I'm trying to change
Comment 2 Dieter 2020-03-24 15:34:08 UTC
*** Bug 131466 has been marked as a duplicate of this bug. ***
Comment 3 Dieter 2020-03-24 15:47:14 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 5dcbd1bb557450a2d658a710c163b310c0cee157
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL

Additional informations:
- happens also when saving as docx
Comment 4 NISZ LibreOffice Team 2020-03-25 13:11:40 UTC
I'm somewhat doubtful that a similar setting exists in Word, looking at my W13 and this tutorial:

https://www.howtogeek.com/344125/how-to-adjust-column-size-in-microsoft-word/

Consequently it would be no surprise that saving this setting does not happen.
Comment 5 Dieter 2020-03-25 13:17:27 UTC
(In reply to NISZ LibreOffice Team from comment #4)
> Consequently it would be no surprise that saving this setting does not
> happen.

So perhaps it also blocks meta bug 88173 (DOCX-Limitations)?
Comment 6 Bart 2020-03-25 15:22:24 UTC
Created attachment 158994 [details]
Checking/unchecking Equal Column width in Word version 14.0
Comment 7 Bart 2020-03-25 15:23:19 UTC
Created attachment 158995 [details]
The document after changing "Equal Columns" in Word
Comment 8 Bart 2020-03-25 15:30:00 UTC
> I'm somewhat doubtful that a similar setting exists in Word

When I run Windows, in Word version 14.0 that setting is found under "Page Layout -> Colums -> Equal Columm Width".

(For your convenience I added image "WordV14EqualColumnWidth.png". Because the setting is in tiny letters, I added an arrow.)

When I uncheck "Equal Column Width", save the document and reopen it in Libre Office Writer, the text on the last page is then in the left column only. 

(I added document "The Actor At Work - Lesson Twenty MW.doc" in case you would want to double-check this yourself.)

From time to time I exchange documents with others. That's why I sometimes check what a document looks like for them before sending it.

If you have more questions or remarks, let me know!

Thanks to all the developers for their hard work. 
(I forgot to add that in my first post.)
Comment 9 Dieter 2020-03-25 15:58:49 UTC
(In reply to Bart from comment #8)
> When I uncheck "Equal Column Width", save the document and reopen it in
> Libre Office Writer, the text on the last page is then in the left column
> only. 

I can't confirm that. And "Equal Column Width" is something different than "Evenly distribute contens to all comlimns".
Comment 10 Bart 2020-03-25 17:00:42 UTC
You are right. I'm sorry.
Comment 11 Bart 2020-03-26 03:02:56 UTC
I hope that I have some additional information about Microsoft Word and how even and uneven columns are done. I hope that this is useful extra information.

It confirms what the NISZ LibreOffice Team already wrote, that a Word document may not contain a setting "Evenly spread out text over both columns".

Here's what I found:

I started a document with Microsoft Word 14 and I added two columns. In the document the columns continued until the end. On the last page (which is also the first page), the text first appeared in the left column, then it continued into the right column. The text was unevenly spread out over the columns. (It's document "WordColsUneven.doc" and image "Word14ColsTillEnd.png") 

Then I made a document that started with one column. After a few lines I changed it to two columns, and near the end I changed it back to one column. Over the two columns Word spreads out the text evenly. (This is document "WordColsEven.doc" and image "Word14ColsEven.png")

Here's what surprised me:

I went back to the document with the "uneven" columns. (That's document "WordColsUneven.doc") I selected the last lines, and clicked "Page Layout -> Columns -> One". I did not change any of the settings of the existing two columns. Suddenly, Word now evenly spreads out the text over both columns. (This is image "Word14SelectLastLines.png")

I also installed Microsoft Office XP and I repeated most of the previous steps. Word 14 and Word XP do the same.

I don't expect the same behavior from Libre Office. That's up to the developers. I added this information, because I hope it helps getting to the cause.

If Microsoft calls this "intellisense", then I have a hard time figuring it out. :p

If a Word document does not contain a setting "Evenly spread out text over both columns", then I'm not sure if my report should still be considered a bug. ;)

I do think that developing Libre Office is a challenge, most of all when trying to keep it compatible with Microsoft Word, and especially when Word shows this type of behavior.

My compliments to all the developers who put their time in the development of Libre Office.
Comment 12 Bart 2020-03-26 03:04:20 UTC
Created attachment 159017 [details]
A document created with Word 14 that shows uneven columns
Comment 13 Bart 2020-03-26 03:05:25 UTC
Created attachment 159018 [details]
A document created with Word 14 that shows uneven columns (screen copy)
Comment 14 Bart 2020-03-26 03:06:35 UTC
Created attachment 159019 [details]
A document created with Word 14 that shows even columns
Comment 15 Bart 2020-03-26 03:07:39 UTC
Created attachment 159020 [details]
A document created with Word 14 that shows even columns (screen copy)
Comment 16 Bart 2020-03-26 03:10:20 UTC
Created attachment 159021 [details]
A document created with Word 14, changing the last lines into one column
Comment 17 Timur 2020-03-26 07:14:54 UTC
Let's review:
- for fileopen bug we need DOC/X created with MSO
- for filesave bug we need ODT from LO
(so not DOC from LO).
And we compare with MSO.

Looks that MSO doesn't have "Evenly distribute contents to all columns" option so I'll mark NotOurBug.
If not correct, feel free to set New. 

There seem to be workaround, one more step in LO before saving as DOC/X:
- after "Evenly distribute .." is turned off and we have text in 1st column only, Insert Column Break.
DOCX opens as expected in MSO. DOC would probably, but except it has empty areas in text (which is another issue, maybe because formats is document are wrong).
Comment 18 Timur 2020-03-26 07:21:28 UTC
Non-dev option would be to insert section additional break after "Evenly distribute contents to all columns" when turned off, if saving to DOC/X.
Let us ask for DevEval.
Comment 19 Mike Kaganski 2020-03-26 07:36:58 UTC
Consider also the two different modes in Word:

1. Making whole document two-columnar (new doc; set layout to 2-column, and choose "Whole document" in "Apply to:"). Irrespective of "Equal column width" setting, it will fill first column before moving to the second.
2. Making a section starting mid-page to be two-column: create three paragraphs first, then select the second one, and format its layout two-column. Then this will always (?) be evenly distributed.

I don't see an easy way to interoperate with Word in absence of the feature in it (?) without hacks like in comment 17. My personal favorite would be "NOTOURBUG" + advise to use PDF for interchange when one needs layout correctness (just IMO; I realize different needs and scenarios - but one must realize that e.g. it's impossible to keep everything exporting to, say, plain text; here it's similar, just limited to a subset of functionality).
Comment 20 Bart 2020-03-26 11:23:04 UTC
There was something else that I noticed along the way. Maybe it's useful, maybe not. I'll leave that up to others.

I noticed that the option "Evenly distribute contents to all columns" sometimes shows, sometimes doesn't show in Libre Office. (Please compare screen copies "LONoOptionEvenlyDistribute.png" and "LOWithOptionEvenlyDistribute.png")

This makes me wonder if other developers have been looking at the same issue in the past and made their choices.

If that's the case, then I hope they added their comments in the source code. ;)
Comment 21 Bart 2020-03-26 11:24:25 UTC
Created attachment 159041 [details]
LONoOptionEvenlyDistribute.png : The option "Evenly distribute columns" is absent
Comment 22 Bart 2020-03-26 11:25:41 UTC
Created attachment 159042 [details]
LOWithOptionEvenlyDistribute.png : The option "Evenly distribute columns" is present
Comment 23 Mike Kaganski 2020-03-26 14:08:41 UTC
(In reply to Bart from comment #20)
> I noticed that the option "Evenly distribute contents to all columns"
> sometimes shows, sometimes doesn't show in Libre Office. (Please compare
> screen copies "LONoOptionEvenlyDistribute.png" and
> "LOWithOptionEvenlyDistribute.png")

When the columnar layout belongs to page style, there's no way to distribute evenly. That is same as with Word, and no interoperability problems here. The difference is when sections are formatted with columns. Word is unable to *not* distribute columns in that case, while Writer provides flexibility.
Comment 24 Timur 2020-03-28 11:27:08 UTC
Let it be NOB.