Bug 131515 - Replacement single quote in the middle from a word
Summary: Replacement single quote in the middle from a word
Status: RESOLVED DUPLICATE of bug 128860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-23 22:47 UTC by Jürgen Kirsten
Modified: 2021-09-20 09:04 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
PDF with the example in German (9.94 KB, application/pdf)
2020-03-23 22:48 UTC, Jürgen Kirsten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Kirsten 2020-03-23 22:47:34 UTC
Description:
In LibreOffice in the options of the Auto-Correction section there is the possibility to replace single quotation marks at the beginning and at the end of the word automatically under Localized Options.
Now there is the circumstance in German language that we have words that have an apostrophe in the middle of the word. For example "mach's gut". The correct spelling is with the right single quotation mark. Code 8217.
LibreOffice replaces my apostrophe already after I have written mach' in a left single quotation mark Code 8216. What is o.K. for quotation mark but not for Apostrophe. LibreOffice does not wait if the apostrophe is really at the end of the word. The replacement should only happen when the apostrophe is actually at the end of the word.

Steps to Reproduce:
1. Open a LibreOffice Document
2. Change the Language in German(Germany)
3. write the Word : mach'
4. write the word complete with "s"

Actual Results:
LO change the apostrophe in a quotation mark

Expected Results:
LibreOffice must wait if the word really ends with an apostrophe. Only then it may replace it with a single quote.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.2.2 (x64)
Build-ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU-Threads: 8; BS: Windows 10.0 Build 18363; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 1 Jürgen Kirsten 2020-03-23 22:48:58 UTC
Created attachment 158911 [details]
PDF with the example in German
Comment 2 Jürgen Kirsten 2020-08-23 19:59:15 UTC

*** This bug has been marked as a duplicate of bug 128860 ***