Bug 131521 - Unable to remove last paragraph between protected sections
Summary: Unable to remove last paragraph between protected sections
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2020-03-24 07:41 UTC by Mike Kaganski
Modified: 2021-09-16 15:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-03-24 07:41:43 UTC
1. In a new text document, add two sections separated by an empty paragraph; put some text into the sections
2. Put cursor to the empty paragraph between sections, press Del

=> the paragraph gets deleted, and the two sections are now adjacent.

3. Undo to get the paragraph between sections back
4. Protect the two sections
5. Try to delete the empty paragraph between the sections like in #2.

=> Nothing happens

Only unprotecting lower section, this would succeed.

Tested with Version: 6.4.2.2 (x64)
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Comment 1 Dieter 2020-03-25 07:42:56 UTC
I confirm it wit

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 5dcbd1bb557450a2d658a710c163b310c0cee157
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL

Result: Message "Write-protected content cannot be changed." appears
Comment 2 psidiumcode 2021-09-16 15:31:26 UTC
I could not reproduce it in version:

Version: 6.4.0.0.beta1+
Build ID: d54bae3471e9b9529f1ac03c811c3370d9f5ed89
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded


I could not reproduce it in version: 

Version: 7.2.0.4 / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 3 Buovjaga 2021-09-16 15:51:01 UTC
Repro

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: b573ce5683ee648ed391ea3223208e584cf2f868
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded Jumbo

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 88a6ac9f75a4375b72111af5a3e004bef4226455
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 15 September 2021
Comment 4 Mike Kaganski 2021-09-16 15:53:01 UTC
(In reply to psidiumcode from comment #2)
> I could not reproduce it in version:
> 
> Version: 6.4.0.0.beta1+
> 
> I could not reproduce it in version: 
> 
> Version: 7.2.0.4 / LibreOffice Community

Unless you *could* reproduce it in some version - especially in the version where the bug was reported, which was 6.4 - you can't assume that the bug WORKSFORME (which means, the bug existed, but was fixed by unknown commit).

What you discovered was simply that in some configuration, the problem does not show up. This is different. Or maybe you just didn't follow the steps carefully.

It is still there in Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL