Bug 131538 - FILESAVE DOCX XLSX file embedded as OLE icon does not open in Word
Summary: FILESAVE DOCX XLSX file embedded as OLE icon does not open in Word
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-OLE-Objects
  Show dependency treegraph
 
Reported: 2020-03-24 14:50 UTC by NISZ LibreOffice Team
Modified: 2023-01-27 14:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Writer (29.02 KB, application/vnd.oasis.opendocument.text)
2020-03-24 14:50 UTC, NISZ LibreOffice Team
Details
The original file saved by Writer (18.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-03-24 14:53 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Word (66.63 KB, image/png)
2020-03-24 14:54 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-03-24 14:50:17 UTC
Created attachment 158942 [details]
Example file from Writer

Attached odt file contains XLSX and XLS file embedded as OLE icon.
When this is saved as DOCX Word cannot open the embedded files, although Writer does open them.


Steps to reproduce:
1.	In Writer choose Insert – Object – OLE Object.
2.	Choose Create from file, select an existing XLSX/XLS file
3.	Check the “Display as icon” box.
4.	The file is inserted as an icon.
5.	Save as DOCX and open in Word

Actual results:
Double clicking on the file in Word gives an error message.

Expected results:
Embedded file is opened by Excel for editing.

LibreOffice details:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 8e323fcacebad1afe9d867b846722a6b9bf20f78
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

Also happens in:
Verzió: 6.0.0.3
Build az.: 64a0f66915f38c6217de274f0aa8e15618924765
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; 
Területi beállítások: hu-HU (hu_HU); Calc: CL

Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (hu_HU)

Before that only a replacement image was exported.
Comment 1 NISZ LibreOffice Team 2020-03-24 14:53:31 UTC
Created attachment 158943 [details]
The original file saved by Writer
Comment 2 NISZ LibreOffice Team 2020-03-24 14:54:45 UTC
Created attachment 158944 [details]
Screenshot of the problem in Word
Comment 3 Dieter 2020-03-27 08:16:43 UTC
(In reply to NISZ LibreOffice Team from comment #0)
> Created attachment 158942 [details]
> Example file from Writer
> 
> Attached odt file contains XLSX and XLS file embedded as OLE icon.
> When this is saved as DOCX Word cannot open the embedded files, although
> Writer does open them.

I can't confirm it with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

and MS Word 2016
Comment 4 Buovjaga 2020-06-15 18:47:10 UTC
NISZ: are you using MSO 2013 or...?
Comment 5 NISZ LibreOffice Team 2020-06-30 12:36:40 UTC
(In reply to Buovjaga from comment #4)
> NISZ: are you using MSO 2013 or...?

Yes the screenshot is on 2013. Have not checked on newer version.
Comment 6 Dieter 2022-02-05 16:08:34 UTC
NISZ, still reproducible in LO 7.3?
=> NEEDINFO
Comment 7 QA Administrators 2022-08-05 03:32:07 UTC
Dear NISZ LibreOffice Team,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INSUFFICIENTDATA
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-NeedInfo-Ping
Comment 8 Aron Budea 2022-08-05 07:32:16 UTC
I have no problem with this in Word / Excel 2013, either.

When ODT is saved as DOCX in LO 7.0.0.3, in Word, when double-clicking the OLE object, the embedded spreadsheet editor view opens within Word.

When performing the same in LO 7.5.0.0.alpha0+ (fc8b757dad5d98f4ba1cd40d03505873128670cd) + Word, the spreadsheet opens separately in Excel, and not in an embedded view.
Comment 9 Gabor Kelemen (allotropia) 2023-01-27 14:06:26 UTC
(In reply to Aron Budea from comment #8)
> I have no problem with this in Word / Excel 2013, either.
> 
> When ODT is saved as DOCX in LO 7.0.0.3, in Word, when double-clicking the
> OLE object, the embedded spreadsheet editor view opens within Word.
> 
> When performing the same in LO 7.5.0.0.alpha0+
> (fc8b757dad5d98f4ba1cd40d03505873128670cd) + Word, the spreadsheet opens
> separately in Excel, and not in an embedded view.

I see the same behavior now in 7.1 (it was open in inline editor in <=7.0, which also changed embedding from icon to content, breaking layout) and newer under Win 10.

Perhaps my old Win8.1 was behaving in interesting ways like in https://bugs.documentfoundation.org/show_bug.cgi?id=138179#c5

Anyhow, let's say this is working fine now.