Download it now!
Bug 131547 - VIEWING At scroll gaps in displayed text with enabled Skia
Summary: VIEWING At scroll gaps in displayed text with enabled Skia
Status: RESOLVED DUPLICATE of bug 131426
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-03-24 18:42 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2020-03-25 15:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file with 6 screenshots to show the problem (2.69 MB, application/x-zip-compressed)
2020-03-24 18:42 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2020-03-24 18:42:44 UTC
Created attachment 158955 [details]
zip file with 6 screenshots to show the problem

In LO 7.0 Writer builds from 2020-03-19 and later (=younger) scrolling by scroll bar or mouse wheel results in gaps in the displayed text. The behavior is the same regardless of whether OpenGL is activated or not.
To show the problem I have opened the same text document with the LO builds from 
/daily/master/Win-x86_64@tb77-TDF/2020-03-18_03.49.36/ and from /daily/master/Win-x86_64@tb77-TDF/2020-03-19_04.02.14/
with and without OpenGL activated. I have made screenshots, contained in the attached zip file.
An other text document I have opened with the LO build from 2020-03-24. The both screenshots do show as well the gaps as also the behavior described in Bug 131543.
The gaps do not occur when navigation within the document is made by keybord (cursor keys, page keys etc.).

The problem only concerns the output on the display. The print output and export e.g. to pdf is made correct.

Because of the same "starting date" (both first seen in builds from 2020-03-19) I guess there is a relation to Bug 131543.
Comment 1 Stefan_Lange_KA@T-Online.de 2020-03-24 22:28:47 UTC
After a comment from V Stuart Foote to Bug 131543 I have checked both bugs, 131543 and 131547, for related settings.
As I have seen the here described problem exists in LO builds starting from 2020-03-19 when Skia is enabled regardless if OpenGL is activated or not.
Comment 2 Telesto 2020-03-25 15:13:05 UTC
Repro
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 7ae9c9572ccac55c0926b8a9779bb63c4236291c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Vulkan; VCL: win; 
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 Stefan_Lange_KA@T-Online.de 2020-03-25 15:36:58 UTC
Seems it is a duplicate of Bug 131426.
Comment 4 Aron Budea 2020-03-25 15:51:15 UTC
(In reply to Stefan_Lange_KA@T-Online.de from comment #3)
> Seems it is a duplicate of Bug 131426.
Yes, I agree, let's dlose as duplicate.

*** This bug has been marked as a duplicate of bug 131426 ***