Download it now!
Bug 131554 - text position wrong for a PPTX document
Summary: text position wrong for a PPTX document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: nd101
URL:
Whiteboard: target:7.0.0 target:6.4.4 target:6.4.5
Keywords: bibisected, filter:pptx, regression
: 128547 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-25 04:07 UTC by nd101
Modified: 2020-05-06 08:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Said document (20.57 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-03-25 04:09 UTC, nd101
Details
result in Impress (3.79 KB, image/png)
2020-03-25 04:09 UTC, nd101
Details
result in MSO (12.76 KB, image/png)
2020-03-25 04:10 UTC, nd101
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nd101 2020-03-25 04:07:06 UTC
Description:
The attached document has the wrong text element layout in Impress

Steps to Reproduce:
1.Open document in Impress
2.The position is incorrect
3.

Actual Results:
Wrong position

Expected Results:
Correct text location as in MSO


Reproducible: Always


User Profile Reset: No



Additional Info:
927f948c4c86887236a0451545ce0ca20ec2
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 1 nd101 2020-03-25 04:09:23 UTC
Created attachment 158963 [details]
Said document
Comment 2 nd101 2020-03-25 04:09:57 UTC
Created attachment 158964 [details]
result in Impress
Comment 3 nd101 2020-03-25 04:10:19 UTC
Created attachment 158965 [details]
result in MSO
Comment 4 nd101 2020-03-25 04:11:13 UTC
We will be submitting a fix
Comment 5 nd101 2020-03-25 05:22:57 UTC
Changes submitted
https://gerrit.libreoffice.org/c/core/+/91023
Comment 6 Xisco Faulí 2020-03-25 10:49:51 UTC
Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: fd1cd5522283f279a01d6d673f676a1346e9358b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.19; Render: default;
Comment 7 Xisco Faulí 2020-03-25 11:17:56 UTC
Hi nd101,
your patch also affects bug 119187, please, take it into account
Comment 8 Xisco Faulí 2020-03-25 11:33:33 UTC
Actually this is a regression.
It was fine until https://cgit.freedesktop.org/libreoffice/core/commit/?id=cc6ae367280d205a88c6f907b20b84613221ca52. Then the 'Template' placeholder was gone until https://cgit.freedesktop.org/libreoffice/core/commit/?id=2a7119021edea8346e4673d57cac3f051a5d0968, when it started to be displayed at its current position
Comment 9 Xisco Faulí 2020-03-25 11:34:38 UTC
*** Bug 128547 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2020-03-25 11:35:36 UTC
@Nd101, you patch fixes the document in bug 128547
Comment 11 Commit Notification 2020-04-01 08:21:49 UTC
nd101 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/69b83dc2d3014dd9b18402534e15c937dc082464

tdf#131554 placeholder iteration fails to stop when a match is found

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-04-02 19:42:27 UTC
nd101 committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/55d423e8f371e914c51f9aa18aacede46355b133

tdf#131554 placeholder iteration fails to stop when a match is found

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Heiko Tietze 2020-04-10 09:43:39 UTC
Guess it's solved.
Comment 14 Xisco Faulí 2020-04-14 18:15:09 UTC
Yes, verified in

Version: 7.0.0.0.alpha0+
Build ID: 35fc5ef0a759884b24ed8b83cd05702a0fab64cc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@nd101, thanks for fixing this issue!
Comment 15 Commit Notification 2020-04-28 13:52:02 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5750be8cf82b6933cb0b44ffe5ad307da1b4a0eb

tdf#132282: Revert fix for tdf#131554

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Serge Krot (CIB) 2020-04-28 14:33:32 UTC
As the patch for this fix was reverted - I set the bug status to REOPENED
Comment 17 Xisco Faulí 2020-04-28 14:39:42 UTC
(In reply to Serge Krot (CIB) from comment #16)
> As the patch for this fix was reverted - I set the bug status to REOPENED

The fix was reverted but the unittest still passes. See the comment in the commit: 

912217285b3058efa54c2336f91fda4efdad6ff0 fixed the
root cause of tdf#131554 and
69b83dc2d3014dd9b18402534e15c937dc082464 is no longer needed
The unittest still passes
Comment 18 Xisco Faulí 2020-04-29 08:24:24 UTC
Textbox position is still correct in

Version: 7.0.0.0.alpha0+
Build ID: cf36fe5eb41910c26d58fb25e54ccf2e0ee01365
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 19 Commit Notification 2020-05-01 15:57:56 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7df4ebf9a658681d02842b14187722ae8161cd7e

tdf#132282: Revert fix for tdf#131554

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-05-06 08:11:02 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-4":

https://git.libreoffice.org/core/commit/3b9283880e8d53c5cbc0eabc1c9119ff673b422c

tdf#132282: Revert fix for tdf#131554

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.