Bug 131605 - Crash in: swlo.dll
Summary: Crash in: swlo.dll
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 131606 132030 (view as bug list)
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-03-26 15:58 UTC by porscholz
Modified: 2020-12-11 09:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["swlo.dll"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description porscholz 2020-03-26 15:58:45 UTC
This bug was filed from the crash reporting server and is br-ad755283-27e2-420a-a9ea-852a9edbdd19.
=========================================

Problem occurs regulary since several weeks.
To fix, meanwhile I've reinstalled LO 64bit, than Win10 v 1909 and LO again. Crash occures sometimes after some minutes, sometimes after hours of workig.
Comment 1 Xisco Faulí 2020-03-26 16:22:46 UTC
*** Bug 131606 has been marked as a duplicate of this bug. ***
Comment 2 Xisco Faulí 2020-03-26 16:23:08 UTC
Thank you for reporting the bug.
Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem.
Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the steps are provided
Comment 3 Dieter 2020-04-14 13:24:58 UTC
*** Bug 132030 has been marked as a duplicate of this bug. ***
Comment 4 porscholz 2020-04-14 16:41:54 UTC
As I wrote in earlier bug report, after days and nights of struggeling with this crashs I found on http://www.ooowiki.de/BedingungenPr(c3bc)fen.html #2 specifications about fieldnames. The original fieldnames of Thunderbird addressbook (in German) don't match these specifications.
Your answer was: Please add some steps to reproduce at bug 131605. For example there are no informations, that it is about field names. It might also be helpful to add a document that shows the bug.

Sorry, I'm not really used to technical Englisch. I wrote about feald names but meant column lables.
It is necessary to define a data query with changed column labels as address data source, with data from the address table it doesn't work. The column labels must meet the criteria described in the link above. As an example I post a form letter template once again.
Comment 5 Dieter 2020-04-14 17:21:38 UTC
Porscholz, thanks for your comment. So I assume, crash occurs, when you work on mail merge (Serienbrief)?

Please add some steps like

1. Open a document in Writer
2. Tools => Mail Merge Wizard (for example, I don't know, if this is the correct step 
3. ....
....
Result: LO crashes

Tip: If you change UI language to English (Extras => Optionen => Spracheinstellungen => Sprachen => Benutzerobefläche) you can describe the steps in English more easy.

Sorry, but again NEEDINFO
Comment 6 porscholz 2020-04-17 11:57:37 UTC
Thanks Dieter,
but I already have described the procedure that leads to a reproducible crash when using the serial letter function:
1. 'Dokument NEU' using template "°Brief formal_AdrB.ott" (already uploaded)
2. Connect to Thunderbird address book "adressen.odb"
3. Selection of one data set, save document
4. Crash (the document is not saved!)
In meantime I could probably rule out that the letter template contains errors and also the "adressen.odb".  Both files can be edited and saved separately.
Unfortunately, my conclusion in comment 4 is not correct: even if I use the letter template not with the addresses out of 'Tabelle', but with the query ('Abfrage')without special characters in the column lables, LO crashes.
What can I do now?
Comment 7 Telesto 2020-04-17 12:19:22 UTC
(In reply to porscholz from comment #6)
> What can I do now?
Short term? Did it work in the past? If so, try LibreOffice 5.4 for example.
https://portableapps.com/apps/office/libreoffice-portable-legacy-5.4

There should be no crash, not sure if will work though.
Comment 8 Julien Nabet 2020-04-17 13:25:36 UTC
On pc Debian x86-64 with master sources updated today, I gave a try with 
attachment from tdf#131621
https://bugs.documentfoundation.org/attachment.cgi?id=159116

I got no crash but I noticed these traces on console:
warn:filter.config:65182:65182:filter/source/config/cache/typedetection.cxx:452: caught exception while querying type of file:///tmp/LibreOffice/Datenbanken/PersAdressbuch.ods com.sun.star.uno.Exception message: Could not open stream for <file:///tmp/LibreOffice/Datenbanken/PersAdressbuch.ods>

Let's consider the whole situation:
you've got 3 files :
- an ods file "PersAdressbuch.ods" (located in a subdir "LibreOffice/Datenbanken")
- an odb file "EmbeddedDatabase" which is linked to "PersAdressbuch.ods"
- ott template file (with an accentuated name since in Bugzilla we got "°Brief formal_AdrB.ott") => please rename your file to avoid accents/special characters.
which contains a datasource Adressen which links to EmbeddedDatabase.odb

Now, did you change the content of one of these files or the location of one these files?
Location is very important. Indeed as I had put in https://bugs.documentfoundation.org/show_bug.cgi?id=131621#c8, I noticed this:
<db:file-based-database xlink:href="../../../LibreOffice/Datenbanken/PersAdressbuch.ods/" db:media-type="application/vnd.oasis.opendocument.spreadsheet" />

Do you have any backup of these files to give a try with a former version?
Again, check the location.
Comment 9 porscholz 2020-04-17 18:45:39 UTC
(In reply to Telesto from comment #7)
> (In reply to porscholz from comment #6)
> > What can I do now?
> Short term? Did it work in the past? If so, try LibreOffice 5.4 for example.
> https://portableapps.com/apps/office/libreoffice-portable-legacy-5.4
> 
> There should be no crash, not sure if will work though.

Starting the projekt I used LO 6.3. I was suggestet, to update to 6.4. I did so, no change could be detected.
Comment 10 porscholz 2020-04-17 19:55:30 UTC
(In reply to Telesto from comment #7)
> (In reply to porscholz from comment #6)
> > What can I do now?
> Short term? Did it work in the past? If so, try LibreOffice 5.4 for example.
> https://portableapps.com/apps/office/libreoffice-portable-legacy-5.4
> 
> There should be no crash, not sure if will work though.

Starting the projekt I used LO 6.3. I was suggestet, to update to 6.4. I did so, no change could be detected.(In reply to Julien Nabet from comment #8)
> On pc Debian x86-64 with master sources updated today, I gave a try with 
> attachment from tdf#131621
> https://bugs.documentfoundation.org/attachment.cgi?id=159116
> 
> I got no crash but I noticed these traces on console:
> warn:filter.config:65182:65182:filter/source/config/cache/typedetection.cxx:
> 452: caught exception while querying type of
> file:///tmp/LibreOffice/Datenbanken/PersAdressbuch.ods
> com.sun.star.uno.Exception message: Could not open stream for
> <file:///tmp/LibreOffice/Datenbanken/PersAdressbuch.ods>
> 
> Let's consider the whole situation:
> you've got 3 files :
> - an ods file "PersAdressbuch.ods" (located in a subdir
> "LibreOffice/Datenbanken")
> - an odb file "EmbeddedDatabase" which is linked to "PersAdressbuch.ods"
> - ott template file (with an accentuated name since in Bugzilla we got
> "°Brief formal_AdrB.ott") => please rename your file to avoid
> accents/special characters.
> which contains a datasource Adressen which links to EmbeddedDatabase.odb
> 
> Now, did you change the content of one of these files or the location of one
> these files?
> Location is very important. Indeed as I had put in
> https://bugs.documentfoundation.org/show_bug.cgi?id=131621#c8, I noticed
> this:
> <db:file-based-database
> xlink:href="../../../LibreOffice/Datenbanken/PersAdressbuch.ods/"
> db:media-type="application/vnd.oasis.opendocument.spreadsheet" />
> 
> Do you have any backup of these files to give a try with a former version?
> Again, check the location.

Thanks for explanation. Sorry, I'm normal LO-user, not a developer, have no systematic backups of earlier file versions (at AppData\Roaming\LibreOffice\4\user\backup there are 100's). And the "Â" in "°Brief formal_AdrB.ott" is unknown to me, I don't use it here.
Very interesting I found your focus on file locations. data base files here are stored in D:\Dokumente\LibreOffice\Datenbanken and templates in D:\Dokumente\LibreOffice\LO-Vorlagen. In order to generate an anonymized version of my addresses from TB for uploading, I converted the adressen.odb into a dbf database and adapted it for test purposes. With this database (now without reference to the TB address book) and the letter template already used in the same storage locations, I was only able to reproduce the reported crashes, even before trying to save the document.
Comment 11 QA Administrators 2020-04-18 03:35:43 UTC Comment hidden (obsolete)
Comment 12 porscholz 2020-04-29 13:06:53 UTC
After endless further attempts to verify the cause of the crash, I now have re-installed LO (v6.4.3.2) with a renamed user folder in order to exclude possible incorrect settings. Transfer of data for example from one record into the template works without any problem. Even with this default settings, using my letter template with the TB address book causes the program to crash (TDF#131605) at the latest when saving the document. Contrary to the screen message, however, the document is not saved (standstill) and therefore cannot be restored during restart.
Comment 14 Dieter 2020-12-08 16:42:32 UTC
A lot of crashes have been fixed during the last 6 month. So could you just try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.