Download it now!
Bug 131612 - Calc: AutoFilter does not update
Summary: Calc: AutoFilter does not update
Status: RESOLVED DUPLICATE of bug 130770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86 (IA32) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-26 20:30 UTC by frnk
Modified: 2020-03-26 22:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Reporter's issue in a spreadsheet format for testing (7.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-03-26 21:40 UTC, Bhavesh Patel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description frnk 2020-03-26 20:30:27 UTC
Description:
I've got a list with some rows and columns
F1     F2=Filter    F3
1      old       xyz
2      new       abc
3      new       cde

The AutoFilter is placed in Headline picking just "new". So I do not see line 1
After updating "3 new cde" => "3 old cde":
* until some weeks ago I had to click on row 1 column 2 "Filter" and then the Filter updated the list, excluding now also line 3
* since some weeks this does not work any more. I have to switch the filter-value from "old" => "new" and then back from "new" => "old" to get the 2 old-lines filtered out.

I'm not when this "feature" started.

Steps to Reproduce:
1.see above
2.
3.

Actual Results:
see in description

Expected Results:
With click on "filter" the lines get excluded, no switch of filter-condition necessary.


Reproducible: Always


User Profile Reset: No



Additional Info:
With click on "filter" the lines get excluded, no switch of filter-condition necessary.
Comment 1 Bhavesh Patel 2020-03-26 21:40:13 UTC
Created attachment 159054 [details]
Reporter's issue in a spreadsheet format for testing

I have created a Calc file with the data table as described in the original bug report. Not sure if this is a bug.
Comment 2 Julien Nabet 2020-03-26 22:45:14 UTC
I suppose you updated LO recently. There's indeed a regression

*** This bug has been marked as a duplicate of bug 130770 ***