Download it now!
Bug 131625 - Failed to load libreoffice with Cairo and QT5
Summary: Failed to load libreoffice with Cairo and QT5
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
Depends on:
Blocks: Qt5
  Show dependency treegraph
 
Reported: 2020-03-27 13:53 UTC by Hans P. Möller
Modified: 2020-03-31 05:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (35.18 KB, text/x-log)
2020-03-28 14:22 UTC, Hans P. Möller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans P. Möller 2020-03-27 13:53:41 UTC
Description:
"SAL_VCL_QT5_USE_CAIRO=true SAL_USE_VCLPLUGIN=qt5 libreoffice" doesn't start and gives the error:
https://bug-attachments.documentfoundation.org/attachment.cgi?id=158005
but "SAL_VCL_QT5_USE_CAIRO=true SAL_USE_VCLPLUGIN=qt5 libreoffice --writer"
works ok. Also calc, draw, impress, base, global, math and web works ok.

Steps to Reproduce:
1. RUN "SAL_VCL_QT5_USE_CAIRO=true SAL_USE_VCLPLUGIN=qt5 libreoffice

Actual Results:
Office crash with "Application Error" in commandline and the following GUI https://bug-attachments.documentfoundation.org/attachment.cgi?id=158005


Expected Results:
Run libreoffice


Reproducible: Always


User Profile Reset: Yes



Additional Info:
When the invidual application is run (calc, draw, impress, base, global, math and web) it owroks ok, i.e.:
"SAL_VCL_QT5_USE_CAIRO=true SAL_USE_VCLPLUGIN=qt5 libreoffice --writer"

please look at:
https://bugs.documentfoundation.org/show_bug.cgi?id=125234#c11
Comment 1 Julien Nabet 2020-03-27 19:37:07 UTC
Could you give a try at https://wiki.documentfoundation.org/QA/FirstSteps ?

Also, would it be possible you attach a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace) I understand, it might be complicated since it depends on how you launch LO.
Comment 2 Hans P. Möller 2020-03-28 14:22:44 UTC
Created attachment 159097 [details]
backtrace

Backtrace of latest 6.4.2.2 Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
Comment 3 Hans P. Möller 2020-03-28 14:26:30 UTC
for got to mention that whith:
SAL_USE_VCLPLUGIN=qt5 SAL_VCL_QT5_USE_CAIRO=true libreoffice6.4 --safe-mode
the problem ALSO happens.
Comment 4 QA Administrators 2020-03-29 02:27:35 UTC Comment hidden (obsolete)
Comment 5 Michael Weghorn 2020-03-30 05:45:47 UTC
I cannot reproduce with either a custom-built master nor with daily build of 2020-03-21:

Version: 7.0.0.0.alpha0+
Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: qt5+cairo; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-03-21_17:20:22
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

also not after deleting my existing profile as mentioned in https://bugs.documentfoundation.org/show_bug.cgi?id=125234#c11:

> I can reproduce this with my current master (7.0) build too: qt5+cairo works with an existing profile but crashes with a fresh one here.

For me, the Start Center opens when I run

 SAL_USE_VCLPLUGIN=qt5 SAL_VCL_QT5_USE_CAIRO=true ./opt/libreofficedev7.0/program/soffice
Comment 6 Hans P. Möller 2020-03-30 11:57:34 UTC
Just tested with latest master and worked OK.
running:
SAL_USE_VCLPLUGIN=qt5 SAL_VCL_QT5_USE_CAIRO=true libreofficedev7.0

Seems fixed in 7.0

Version: 7.0.0.0.alpha0+
Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: qt5+cairo; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-03-21_17:20:22
Locale: en-US (C); UI-Language: en-US
Calc: threaded



(In reply to Michael Weghorn from comment #5)
> I cannot reproduce with either a custom-built master nor with daily build of
> 2020-03-21:
> 
> Version: 7.0.0.0.alpha0+
> Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab
> CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: qt5+cairo; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2020-03-21_17:20:22
> Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> also not after deleting my existing profile as mentioned in
> https://bugs.documentfoundation.org/show_bug.cgi?id=125234#c11:
> 
> > I can reproduce this with my current master (7.0) build too: qt5+cairo works with an existing profile but crashes with a fresh one here.
> 
> For me, the Start Center opens when I run
> 
>  SAL_USE_VCLPLUGIN=qt5 SAL_VCL_QT5_USE_CAIRO=true
> ./opt/libreofficedev7.0/program/soffice
Comment 7 Michael Weghorn 2020-03-31 05:07:18 UTC
(In reply to Hans P. Möller from comment #6)
> Just tested with latest master and worked OK.
> running:
> SAL_USE_VCLPLUGIN=qt5 SAL_VCL_QT5_USE_CAIRO=true libreofficedev7.0
> 
> Seems fixed in 7.0

Thanks for retesting. Closing as WORKSFORME then.