Bug 131628 - Table cell with border on the bottom gets border repeated on top if there is only one table row in a page
Summary: Table cell with border on the bottom gets border repeated on top if there is ...
Status: RESOLVED DUPLICATE of bug 99923
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-Borders
  Show dependency treegraph
 
Reported: 2020-03-27 16:10 UTC by sergio.callegari
Modified: 2020-03-29 05:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Document showing the problem (9.00 KB, application/vnd.oasis.opendocument.text)
2020-03-27 16:10 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2020-03-27 16:10:00 UTC
Description:
If you build a table spanning multiple pages, cell borders start having weird behaviors.

When your table ends in such a way that there is only one row in the last page, any border applied to the bottom of the cells in this last row gets repeated on top of the cells.

See the attached document for an example.

Steps to Reproduce:
Open a new document

Insert a table

Keep adding rows until the table starts spanning two pages.

Assure that in the second page there is only one row

Select a cell in this last row, apply a bottom border to the cell 

Actual Results:
The border is repeated on the top of the cell

Expected Results:
The border should only be at the bottom where it was applied.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 sergio.callegari 2020-03-27 16:10:47 UTC
Created attachment 159073 [details]
Document showing the problem
Comment 2 Dieter 2020-03-29 05:58:59 UTC

*** This bug has been marked as a duplicate of bug 99923 ***