Bug 131635 - Selection rectangle persists after de-selection/selection change
Summary: Selection rectangle persists after de-selection/selection change
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2020-03-27 19:27 UTC by Eyal Rozenberg
Modified: 2020-04-02 18:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Inappropriately persistent selection and a newer selection (21.84 KB, image/png)
2020-03-27 19:27 UTC, Eyal Rozenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2020-03-27 19:27:25 UTC
Created attachment 159075 [details]
Inappropriately persistent selection and a newer selection

I'm experiencing an issue with selection highlighting - the selection rectangle - which I cannot reproduce, so I'll give some context.

I'm editing a document in Writer, which originally had been imported from a .docx but has since undergone a lot of editing in earlier versions of LO writer. It's an RTL document, with text in Hebrew. I was messing with the selection - I vaguely remember using Shift+Arrow keys and perhaps just arrow-key movement, or Cltr+Arrow key at some point - can't remember exactly. Anyway, I ended up deselecting, perhaps via typing another character, and - some of the selection rectangle persisted and didn't disappear. Now, it's just "in there"; if I scroll back and forth, it scrolls with the text, including when I scroll it out of and back into view. Typing doesn't change its location though - so I can repalce the text under it. I can also make other selections - that doesn't affect it. See attachment for an example

Version info:
version: 6.4.0.3
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: he-IL (en_IL); UI-Language: en-US
Calc: threaded
Comment 1 Eyal Rozenberg 2020-03-27 19:35:34 UTC
The small rectangle is the persisted one.
Comment 2 Dieter 2020-04-02 15:36:37 UTC
Eyal, I understand the problem, but I have no idea how to reproduce the bug, which is needed to change status to NEW.

So please give some steps or attach at least the problematic document. If this is not possible we should close this bug as RESOLVED INSUFFICIENTDATA

=> NEEDINFO
Comment 3 Eyal Rozenberg 2020-04-02 16:58:52 UTC
(In reply to Dieter from comment #2)
Fair enough, but - I can't reproduce this myself. And it's not related to some specific document (and certainly does not last quitting and restarting LO writer).

I don't have anything else I can add. Sorry.
Comment 4 Dieter 2020-04-02 18:10:08 UTC
(In reply to Eyal Rozenberg from comment #3)
> I don't have anything else I can add. Sorry.

So let's close this bug. Feel free to change it back to UNCONFIRMED, if you can provide further informations that can help to reproduce it.