Bug 131645 - Wrong line width representation in an ole draw object
Summary: Wrong line width representation in an ole draw object
Status: RESOLVED DUPLICATE of bug 132169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-03-28 14:07 UTC by Carlo
Modified: 2020-05-14 08:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
This is a test document (236.14 KB, application/document)
2020-04-16 18:48 UTC, Carlo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo 2020-03-28 14:07:27 UTC
Description:
When I insert an ole draw object in a writer document and I insert a line with a width <0,03 mm the line width visualized is wrong after exiting ole edit mode.

Steps to Reproduce:
1.Create a new writer document
2.Insert an ole draw object
3.Insert a line with a width <0,03 mm and exit edit mode

Actual Results:
The line width in edit mode is ok.
When I close the ole edit mode the line with visualised is wrong: more thick.

Expected Results:
The line width must be the same.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Versione: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
Thread CPU: 4; SO: Mac OS X 10.14.6; Resa interfaccia: predefinito; VCL: osx; 
Versione locale: it-IT (it_IT.UTF-8); Lingua interfaccia: it-IT
Calc: threaded
Comment 1 Carlo 2020-03-28 15:06:38 UTC
I inserted an erroneous measure unit. Not mm but cm.
Comment 2 Dieter 2020-04-14 13:19:10 UTC
I can't confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 962b415edb47187737a5f05c4ff3f6724a19c564
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Tested with a width of 0,02 cm.

Could you please add a sample document? Pershaps this makes it easier wo reproduce the bug. Thank you.

=> NEEDINFO
Comment 3 Carlo 2020-04-16 18:48:05 UTC
Created attachment 159640 [details]
This is a test document

This document was created with libreoffice 6.4.2. The screenshot show the problem.
Comment 4 eisa01 2020-05-02 18:33:07 UTC
Can confirm. The 0.02 cm line is rendered too thick (more like 2 cm)

Not present on LO 3.3, and not on Linux

Version: 6.4.3.5
Build ID: 4db9852e73d9e9d662fc8a2783bace79addf1805
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2020-05-14 08:13:43 UTC
it seems to be a duplicate of bug 132169

*** This bug has been marked as a duplicate of bug 132169 ***