Download it now!
Bug 131659 - Spellcheck doesn't mark bad words with non-english dictionaries
Summary: Spellcheck doesn't mark bad words with non-english dictionaries
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking RTL-Hebrew
  Show dependency treegraph
 
Reported: 2020-03-29 12:05 UTC by Daniel Hevron Pereh
Modified: 2020-05-22 10:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Hevron Pereh 2020-03-29 12:05:44 UTC
Description:
though everything works fine with English dictionary, using another dictionaries (in my case, Hebrew) doesn't mark wrong words with red line. The software does recognize the dictionary since pressing F7 the spellcheck takes me through all the bad words and gives sensible alternatives.
using the exact steps below between 6.3.x and 6.4.x, I found out the problem started in 6.4 and wasn't fixed yet.

If its relevant, the issue happened on multiple machines, wayland and xorg, nouveou and proprietary nvidia drivers.

Steps to Reproduce:
1. install libreoffice and hunspell-he 
2. set locale settings to Hebrew, user interface remains in english.
3. in Default Languages for Documents, set complex text layout to Hebrew. It shows an icon indicating that the software detects the dictionary.
4. apply the new settings, restart writer for changes to take affect
5. type in Hebrew

Actual Results:
no marking appears for wrong words (not Hebrew and not English). (the same steps were tested in 6.3.x and it works fine)

Expected Results:
marking appears under wrong words. for both languages


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.2.2
Build ID: 6.4.2-1
CPU threads: 6; OS: Linux 5.5; UI render: default; VCL: gtk3; 
Locale: he-IL (en_IL.UTF-8); UI-Language: en-US
Calc: threaded

Big thank you for the team :)
Comment 1 Daniel Hevron Pereh 2020-05-21 18:05:06 UTC
I have tested the bug on Libreoffice 7.0 alpha release (AppImage, Fedora 32) and happy to say it is resolved there. I don't really understand these things but is there any chance on importing the fix to 6.4.X?
Comment 2 Dieter 2020-05-22 06:45:22 UTC
(In reply to Daniel Hevron Pereh from comment #1)
> I have tested the bug on Libreoffice 7.0 alpha release (AppImage, Fedora 32)
> and happy to say it is resolved there. I don't really understand these
> things but is there any chance on importing the fix to 6.4.X?

Since it is not clear, what patch fixed that issue, I think it is not possible to answer this question. Have you tried with 6.4.4?

Since it works in 7.0.0.0alpha1 let's close it as WORKSFORME
Comment 3 Daniel Hevron Pereh 2020-05-22 10:06:43 UTC
(In reply to Dieter from comment #2)
> (In reply to Daniel Hevron Pereh from comment #1)
> > I have tested the bug on Libreoffice 7.0 alpha release (AppImage, Fedora 32)
> > and happy to say it is resolved there. I don't really understand these
> > things but is there any chance on importing the fix to 6.4.X?
> 
> Since it is not clear, what patch fixed that issue, I think it is not
> possible to answer this question. Have you tried with 6.4.4?
> 
> Since it works in 7.0.0.0alpha1 let's close it as WORKSFORME

It's not working on 6.4.4. Guess I'll wait for the 7.0.0 release. 
thank you for your work :)