Download it now!
Bug 131667 - Calc: UI: Edit Cut (or Ctrl+X) without effect - does not cut nor change the clipboard
Summary: Calc: UI: Edit Cut (or Ctrl+X) without effect - does not cut nor change the c...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-29 14:59 UTC by info@kgsw.de
Modified: 2020-06-09 20:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc sheet file with the pasted web site table data (14.15 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-03-29 15:02 UTC, info@kgsw.de
Details
screen record (1min30s?) of cut out and paste using ctrl+x/v and edit menu (3.83 MB, video/x-matroska)
2020-03-29 15:03 UTC, info@kgsw.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description info@kgsw.de 2020-03-29 14:59:16 UTC
Description:
made a copy from webSite table and paste (with more intermediate steps and also a transpose operation) to and within Calc, which may pasted more than visual data?

found the date of each headline (product info) of the orignal html page missing, but mixed up within another last lines column content, well...

tried to extract that part via cut&paste:
- cut seemed to happen in the editing line (that one above the spreadsheet but under the menu bar)
- but paste to a new destination cell only pasted previous (last used) content
(so clipboard had not changed)
- and source cell still has old, unchanged content

// I donno how to describe it better, but will add file and screen record - and after some hours of trying, I'm lost of any further clues...

Steps to Reproduce:
1. This may be due to the pasted content from a (third party) website, which may contain other or additional characters - but even then I do not expect that behaviour
2. the content of J7 is mixed from original html table, so I tried to seperate the data:
-- do some copy to clipboard (eg. from other application/text) to identify "wrong content" -- 
3. click into J7 - content of cell is shown in editing line
4. in editing line, mark the ending part of the content (here product type) with mouse and press Ctrl+X (to cut out)
5. click into empty cell, eg. C11, and press Ctrl+V


Actual Results:
a) the paste does insert previous / old content from clipboard (not changed by Ctrl+X)
b) the source cell did not change content due to cut-out, 
as the edit line corret feedback first suggested

Expected Results:
the cut in the edit line should take place and change the source cell and the clipboard - if it is due to unvisible characters or other data


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
same happens by using the Menu (Edit > Cut, Edit > Paste)

Version: 6.4.2.2
Build ID: libreoffice-6.4.2.2-snap1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.2.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Comment 1 info@kgsw.de 2020-03-29 15:02:14 UTC
Created attachment 159124 [details]
Calc sheet file with the pasted web site table data
Comment 2 info@kgsw.de 2020-03-29 15:03:55 UTC
Created attachment 159125 [details]
screen record (1min30s?) of cut out and paste using ctrl+x/v and edit menu
Comment 3 Telesto 2020-05-06 21:32:29 UTC
1. Open the attached file
2. Select J5
3. Select Western in the formula bar & notice the selection in J5
4. Copy the selection
5. Paste ->  € 309,90 gets pasted..

Found in 4.4.7.2 but not in 3.5.7.2
Comment 4 Buovjaga 2020-06-09 20:11:20 UTC
(In reply to Telesto from comment #3)
> 1. Open the attached file
> 2. Select J5
> 3. Select Western in the formula bar & notice the selection in J5
> 4. Copy the selection
> 5. Paste ->  € 309,90 gets pasted..
> 
> Found in 4.4.7.2 but not in 3.5.7.2

This is misleading. The same problem happens all the way back to last35onmaster in Linux 43all repo. With the oldest, we can not select "Western" - instead it selects the whole hyperlink that starts with "Western".

"J5" in the steps is apparently "J2" based on the euros mentioned.

The procedure I used was to use Edit - Copy and right-click paste to some other cell. The result was always empty or had some old clipboard content.