Download it now!
Bug 131677 - LibreOffice doesn't quit after crash & blocks relaunch
Summary: LibreOffice doesn't quit after crash & blocks relaunch
Status: RESOLVED DUPLICATE of bug 133770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-29 16:06 UTC by Telesto
Modified: 2020-06-09 18:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-03-29 16:06:02 UTC
Description:
LibreOffice doesn't quit after crash & blocks relaunch

Steps to Reproduce:
1. Open attachment 157129 [details] (bug 129101)
2. CTRL+A & CTRL+C
3. CTRL+N
4. CTRL+V
5. CTRL+Z -> Crash
6. Press OK in the crash manager.. wait until LibO disappears
7. Attempt to restart LibreOffice -> Keeps loading again & again

Actual Results:
Crashed process doesn't quit

Expected Results:
Should be quiting after disappearing


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 7ae9c9572ccac55c0926b8a9779bb63c4236291c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-03-29 20:52:51 UTC
Same issue when follow these steps (bug 131684)
1. Open attachment 155421 [details]
2. CTRL+A 3x (select everything)
3. CTRL+X
4. CTRL+Z
5. CTRL+V
6. CTRL+Z

Like a duplicate (rather common steps), but can't be sure without proper BT
Comment 2 Dieter 2020-03-30 09:43:25 UTC
(In reply to Telesto from comment #0)
> Description:
> LibreOffice doesn't quit after crash & blocks relaunch
> 
> Steps to Reproduce:
> 1. Open attachment 157129 [details] (bug 129101)
> 2. CTRL+A & CTRL+C
> 3. CTRL+N
> 4. CTRL+V
> 5. CTRL+Z -> Crash
> 6. Press OK in the crash manager.. wait until LibO disappears
> 7. Attempt to restart LibreOffice -> Keeps loading again & again

I can't confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 1c9ced04189c9d23ffea05d5570960b54b05ef28
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL
Comment 3 Dieter 2020-03-30 09:55:04 UTC
(In reply to Telesto from comment #1)
> Same issue when follow these steps (bug 131684)
> 1. Open attachment 155421 [details]
> 2. CTRL+A 3x (select everything)
> 3. CTRL+X
> 4. CTRL+Z
> 5. CTRL+V
> 6. CTRL+Z
> 
> Like a duplicate (rather common steps), but can't be sure without proper BT

I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 1c9ced04189c9d23ffea05d5570960b54b05ef28
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL

Additional information: LO always stops at "Synchronising repository ..."

But not with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

LO crashes also in 6.3.5.2 (crashreport.libreoffice.org/stats/crash_details/89731824-2974-4cb8-837e-bc14a8dd12f0) but it doesn't block relaunch.
Comment 4 Telesto 2020-04-18 16:07:45 UTC
See also bug 132210 comment 2 (also in LibO 6.4.3)
Comment 5 Buovjaga 2020-06-09 17:34:51 UTC
(In reply to Telesto from comment #4)
> See also bug 132210 comment 2 (also in LibO 6.4.3)

As this was fixed, should you re-test?
Comment 6 Telesto 2020-06-09 18:22:08 UTC
Still around..
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 59939d2490726336546c7ad05082d23031074e12
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

Moving to bug 133770 -> has the proper title

*** This bug has been marked as a duplicate of bug 133770 ***