Bug 131768 - Risk of unintended document sharing if the inserting PDF image feature is used
Summary: Risk of unintended document sharing if the inserting PDF image feature is used
Status: RESOLVED DUPLICATE of bug 114234
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: PDF-Insert Privacy
  Show dependency treegraph
 
Reported: 2020-04-01 10:08 UTC by Telesto
Modified: 2020-09-17 12:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (308.13 KB, application/vnd.oasis.opendocument.text)
2020-04-01 10:09 UTC, Telesto
Details
Mockup to interactively select the PDF page (48.60 KB, image/png)
2020-04-03 11:04 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-04-01 10:08:52 UTC
Description:
Risk of unintended document sharing if the inserting PDF image feature is used

Steps to Reproduce:
1. Open the attached file
2. Only when page shown
3. Open the odt (as zip) Go to picture directory and open the source PDF (notice page 2)

Actual Results:
The source document for the PDF image is added completely to the saved file

Expected Results:
Not sure what the best solution would be. 
- Extract only the first page? 
- A warning insert image from multipage PDF document which will be added in full to the ODT/ ODS etc..


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4501a0ba623ad61c5a4e0b807da2e96f0e4ce82c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-04-01 10:09:10 UTC
Created attachment 159212 [details]
Example file
Comment 2 Timur 2020-04-01 13:14:59 UTC
No. I guess you inserted PDF and only 1st page is shown. Who inserted he knew about the whole PDF, not extracting.

Cause is that PDF shows just 1st page. PDF was added in bug 89727.
This is a duplicate of bug 114234 .
You should've searched that before reporting.

*** This bug has been marked as a duplicate of bug 114234 ***
Comment 3 Telesto 2020-04-01 13:37:21 UTC
(In reply to Timur from comment #2)
> No. I guess you inserted PDF and only 1st page is shown. Who inserted he
> knew about the whole PDF, not extracting.
> 
> Cause is that PDF shows just 1st page. PDF was added in bug 89727.
> This is a duplicate of bug 114234 .
> You should've searched that before reporting.
> 
> *** This bug has been marked as a duplicate of bug 114234 ***

Yes, I should usage search more. And yes, bug 114234 is related. But this is about the whole PDF being inserted into the ODT/ODS. I'm not so sure everybody realizes that the whole PDF will be embedded into the ODS, if he/she only wants to add one image from a PDF. Even if, there is a selector as described in bug 114234.

Another issue that if a PDF image is used out of a large document (say LibreOffice PDF manual), the whole PDF (40 MB?) is embedded, creating exceptional large files

I prefer some more opinions about this
Comment 4 Heiko Tietze 2020-04-03 11:04:13 UTC
Created attachment 159295 [details]
Mockup to interactively select the PDF page

Work is ongoing to select the page from the inserted PDF, which also should make it clear that all pages were added. The mockup shows an overlay on mouse hoover with large triangles to click through the pages. The left controls has a disabled look because of p1. Was thinking to have these controls in the margins in order to have a cleaner layout but the inserted image might be small and the controls feel detached in this case.

Additional to the better feedback we should introduce some kind of document minimizer that strips off other pages. Single page PDF-images don't show the interactive controls, of course.
Comment 5 Thomas Lendo 2020-09-06 19:47:31 UTC
For me as for Timur, this is a duplicate of Bug 114234 - Dialog for the inserting/opening of images/pdfs with multiple pages.

When people are aware that they import more than one page and they can choose which page(s) they can insert, then this bug is solved too. I don't see the difference here or the need to complicate the UI or workflow unnecessarily?
Comment 6 Heiko Tietze 2020-09-17 10:57:24 UTC
(In reply to Thomas Lendo from comment #5)
> For me as for Timur, this is a duplicate of Bug 114234 - Dialog for the
> inserting/opening of images/pdfs with multiple pages.
> 
> When people are aware that they import more than one page and they can
> choose which page(s) they can insert, then this bug is solved too. I don't
> see the difference here or the need to complicate the UI or workflow
> unnecessarily?

Accepted but after adding more than one page you may want to scroll. You don't want to split an animated image into single frames. Nor have all pages separated in case of PDFs.

*** This bug has been marked as a duplicate of bug 114234 ***
Comment 7 V Stuart Foote 2020-09-17 12:48:54 UTC
(In reply to Heiko Tietze from comment #6)

> Accepted but after adding more than one page you may want to scroll. You
> don't want to split an animated image into single frames. Nor have all pages
> separated in case of PDFs.
> 
> *** This bug has been marked as a duplicate of bug 114234 ***

Unlikely, the ipdf (pdfium based) 'Insert as image' filter will only render 1 page, the 1st as currently or as selected with work on bug 114234; the privacy issue here is that the full PDF remains in the ODF archive for high resolution printing.  Needed tweak is to delete all but the selected page from the PDF held in ODF while inserting the image.