Download it now!
Bug 131804 - Crash: ucrtbase!abort+0x4e
Summary: Crash: ucrtbase!abort+0x4e
Status: RESOLVED DUPLICATE of bug 135084
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-04-01 20:15 UTC by Telesto
Modified: 2020-07-23 21:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (517.50 KB, application/vnd.oasis.opendocument.text)
2020-04-01 20:16 UTC, Telesto
Details
Screencast (4.31 MB, video/mp4)
2020-04-01 20:16 UTC, Telesto
Details
BT without symbols (17.71 KB, text/plain)
2020-04-01 20:18 UTC, Telesto
Details
Ctrl+A selection rectangle is partial (564.96 KB, image/jpeg)
2020-04-02 14:29 UTC, Bhavesh Patel
Details
Ctrl-V result (602.51 KB, image/jpeg)
2020-04-02 14:31 UTC, Bhavesh Patel
Details
bt with debug symbols (gen) (11.00 KB, text/plain)
2020-04-02 15:53 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-04-01 20:15:34 UTC
Description:
ucrtbase!abort+0x4e

Steps to Reproduce:
1. Open the attached file (i'm recycling old bug doc, not sure where to find the original)
2. CTRL+A 
3. CTRL+X
4. CTRL+N
5. CTRL+V
6. Scroll to top
7. Insert Chart
8. Deselect the chart by clicking somewhere outside
9. Select the chart, Right Click cut
10. CTRL+Z (3x times? until blank document)
11. Press CTRL+Y twice or three times -> crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4501a0ba623ad61c5a4e0b807da2e96f0e4ce82c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-04-01 20:16:06 UTC
Created attachment 159245 [details]
Example file
Comment 2 Telesto 2020-04-01 20:16:28 UTC
Created attachment 159246 [details]
Screencast
Comment 3 Telesto 2020-04-01 20:18:06 UTC
Created attachment 159247 [details]
BT without symbols
Comment 4 Telesto 2020-04-01 20:20:06 UTC
Same crash (without bug report)
Versie: 6.4.0.2 (x86)
Build ID: 08d19fecdc7a2298d051e19cfdb7c35544855fc3
CPU-threads: 4; Besturingssysteem: Windows 6.3 Build 9600; UI-render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-taal: nl-NL
Calc: CL
Comment 5 Bhavesh Patel 2020-04-02 14:29:38 UTC
Created attachment 159269 [details]
Ctrl+A selection rectangle is partial

Ctrl+A selects everything but selection rectangle does not cover last few pages.
Comment 6 Bhavesh Patel 2020-04-02 14:31:12 UTC
Created attachment 159270 [details]
Ctrl-V result

Ctrl-V pastes everything but after "References" heading, the rest of the page is blank and content is pushed down to the next page.
Comment 7 Bhavesh Patel 2020-04-02 14:53:06 UTC
Following Bugs are very similar to this one. 

https://bugs.documentfoundation.org/show_bug.cgi?id=126504
https://bugs.documentfoundation.org/show_bug.cgi?id=126910
https://bugs.documentfoundation.org/show_bug.cgi?id=127329

*** This bug has been marked as a duplicate of bug 126504 ***
Comment 8 Telesto 2020-04-02 15:05:13 UTC
(In reply to Bhavesh Patel from comment #7)
> Following Bugs are very similar to this one. 
> 
> https://bugs.documentfoundation.org/show_bug.cgi?id=126504
> https://bugs.documentfoundation.org/show_bug.cgi?id=126910
> https://bugs.documentfoundation.org/show_bug.cgi?id=127329

@Julien
Would you mind to do a BT to check if there is some similarity with given bugs (if you're able to reproduce). My BT (without code) appears quite different. Steps are indeed similar as Bhavesh Patel noted, but i'm reluctant to add it as duplicate
Comment 9 Julien Nabet 2020-04-02 15:53:38 UTC
Created attachment 159272 [details]
bt with debug symbols (gen)

Here's a bt retrieved on pc Debian x86-64 with master sources updated today + enable-dbgutil + gen rendering.
Comment 10 Dieter 2020-04-08 09:06:22 UTC
I confirm the crash with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

I don't recieve a link to a crash report
Comment 11 Telesto 2020-07-23 21:34:08 UTC
bug 135084 is easier bt the same

*** This bug has been marked as a duplicate of bug 135084 ***