Download it now!
Bug 131873 - Libreoffice-Impress Error adding rows to data table (gtk3 only)
Summary: Libreoffice-Impress Error adding rows to data table (gtk3 only)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.4
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-04 11:42 UTC by Cliff Carson
Modified: 2020-04-16 17:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Home data usage charts (38.40 KB, application/vnd.oasis.opendocument.presentation)
2020-04-04 11:47 UTC, Cliff Carson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cliff Carson 2020-04-04 11:42:33 UTC
Description:
Have a simple two item chart and when I try to add rows to the data table the columns expand. Display the data table and try to move the cursor to the bottom so that I can add a row and as soon as I go to the second row two empty columns are added. When I get to the bottom the screen fills with empty columns.

Steps to Reproduce:
1.Edit the chart and display the data (two columns of data in the example)
2.scroll down the data table and two additional empty data are displayed 
3.scroll to the bottom and the screen is filled with empty columns

Actual Results:
Unable to add addition information into the data table

Expected Results:
Be able to scroll to the bottom, add an addition row, and enter new information.


Reproducible: Always


User Profile Reset: No



Additional Info:
Submitted this bug information into Ubuntu 20.04 bug database under #1863785.  Have failing Impress file attached there.
Comment 1 Cliff Carson 2020-04-04 11:47:52 UTC
Created attachment 159318 [details]
Home data usage charts
Comment 2 Julien Nabet 2020-04-04 20:17:45 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this only with gtk3 rendering, not with gen or kf5 renderings.

As a workaround for the moment, you can try this:
- open a terminal
- export SAL_USE_VCLPLUGIN=gen
- launch LO
Comment 3 Julien Nabet 2020-04-04 20:18:26 UTC
Caolán: thought you might be interested in this one since it's specific to gtk3.
Comment 4 Julien Nabet 2020-04-04 21:01:18 UTC
I don't know if it's related but I noticed that I click on a cell and use scroll wheel of the mouse, I can increase or decrease value of the cell.
Comment 5 Commit Notification 2020-04-05 13:54:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/66b5cbf67b3966ca160a50096d982b3822f08bee

tdf#131873 data table fills with extra columns during scroll

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-04-05 19:07:09 UTC
that problem is fixed in master with a backport in gerrit for 6-4 (https://gerrit.libreoffice.org/c/core/+/91713)

There is an additional master-only issue with focus fixed with https://gerrit.libreoffice.org/c/core/+/91727
Comment 7 Commit Notification 2020-04-05 19:44:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6769c358b7975d118a6762780a17278ce0ac6b8d

Related: tdf#131873 focus-on-click in data browser

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Julien Nabet 2020-04-05 20:09:30 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this anymore.
Thank you Caolán!
Comment 9 Commit Notification 2020-04-16 17:04:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f4dec59b6484e4fc059883d9a1d17a604290e720

tdf#131873 data table fills with extra columns during scroll

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.