Bug 131875 - Allow dragging and dropping of shapes from the Sidebar
Summary: Allow dragging and dropping of shapes from the Sidebar
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar
  Show dependency treegraph
 
Reported: 2020-04-04 12:54 UTC by Prabesh432@gmail.com
Modified: 2020-06-22 04:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Prabesh432@gmail.com 2020-04-04 12:54:57 UTC
Description:
We can design so easily. Its very noob friendly. I wish, LO Devs copy their entire feature and implement it on LO Draw in similar manner.

Steps to Reproduce:
1. We can create any diagrams easily.
2. There is a dedicated "Diagram" section to increase fonts, line size, etc.
3. The way we can increase the curves of the symbol is amazing.
4. The dotted pattern in the background which disappears after saving the picture is a nice concept. Those tiny rectangle & square in the drawing page will scale with user mobility and help use easy drag and drop two connecting points.
5. The ability to copy the above triangle right below it is amazing. The way we do this on this site very helpful. 
6. In this site, if u try to merge two figures, the site release that. And simply connect two lines, which makes things easier. Suppose I am trying to connect an arrow pointed line to a side rectangle in the middle part of the line, it connects it exactly there. We don't need to hover our mouse many times.

Everything is done mathematical anglewise. This is why whatever we draw, there is perfection. That's their way of doing things.

Try to use this for a day or two, u will love how easy it is to design things. They designed it very simply.

Actual Results:
I connect do these things easily from LO Drawer. 

The way we can draw arrows, rectangle, etc and bend it with more accuracy and details on that website is the vast difference if u do the same on LO Drawer. U might see an hour of the time difference.

Expected Results:
I really wish LO Draw as a more similar design approach and outranks that website. Maybe its a UI or something, but I really think LO is not that easy to use. It not straight foward as this website.


Reproducible: Always


User Profile Reset: No



Additional Info:
(Sorry If I made a bad enhancement request. Try using their website for a day or two and u will indeed see the difference. The harder way in LO Draw VS the simpler way in the site from the newbie perspective. Even if u are advance LO Draw user, u will see the difference.) 

Demo: https://imgur.com/bfqEYUh
Comment 1 Timur 2020-04-07 09:21:56 UTC
What exactly (one or more issues) need to be changed in LO to be better?
(Not: "do like them" but "LO feature X does this and should do that").
Comment 2 Prabesh432@gmail.com 2020-04-07 10:40:35 UTC
(In reply to Timur from comment #1)
> What exactly (one or more issues) need to be changed in LO to be better?
> (Not: "do like them" but "LO feature X does this and should do that").

It's hard to explain in words. But I will try:

1. Draw and Drop of figures, shapes, etc. 
2. Ability to bend them as if we are bending it in a bar graph. The graph behind will help the user in each move.
3. A big flat drawing page instead of a page which looks like a word document.
4. Let user draw and save or export in jpeg, png, etc format and let us insert that picture in LO Writer. (Students need this a lot. I cannot do this on LO Draw. It's hard to achieve this.)


5. When the user draws something and saves/export that image/figure; then we only need that image portion, not the entire page. This figure can be used in other documents. As mentioned in 4th point.

6. A virtual angle. If I need to insert two rectangle side by side with some gap. A virtual angle will show where exactly I should put the 2nd rectangle. This is very hard in LO Draw when u need to insert like 20 of them up and down, side by side in a similar distance. 

(That's I used that website as a reference.)
Comment 3 Buovjaga 2020-06-19 13:49:39 UTC
(In reply to Prabesh432@gmail.com from comment #2)
> 1. Draw and Drop of figures, shapes, etc. 

Ok, let's change this report to be about this.

Currently, you can directly add shapes into the document by Ctrl-clicking them in the Drawing toolbar. This does not work with the Sidebar Shapes deck. Also, dragging and dropping would allow the user to immediately position the shape.

The graphics in the Gallery are draggable and droppable since forever.

> 2. Ability to bend them as if we are bending it in a bar graph. The graph
> behind will help the user in each move.

Please create a new report for this and describe it in much more detail, preferably referring to the help page of another application.

> 3. A big flat drawing page instead of a page which looks like a word
> document.

I don't understand what this means in practice. If you report it as a new request, please describe what you mean. One guess I have is you mean an inifinite canvas. That's not really aligned with the document model, however.

> 4. Let user draw and save or export in jpeg, png, etc format and let us
> insert that picture in LO Writer. (Students need this a lot. I cannot do
> this on LO Draw. It's hard to achieve this.)

Already possible. In Writer, Paste special: Bitmap. In Draw, File - Export, select the image format you want and optionally tick "Selection".

> 5. When the user draws something and saves/export that image/figure; then we
> only need that image portion, not the entire page. This figure can be used
> in other documents. As mentioned in 4th point.

Already addressed in my answer above.

> 6. A virtual angle. If I need to insert two rectangle side by side with some
> gap. A virtual angle will show where exactly I should put the 2nd rectangle.
> This is very hard in LO Draw when u need to insert like 20 of them up and
> down, side by side in a similar distance. 
> 
> (That's I used that website as a reference.)

There are related requests:
bug 125107
bug 100141
bug 74317
bug 127507
https://bugs.documentfoundation.org/showdependencytree.cgi?id=100155&hide_resolved=1

If you still think another request would be needed, do create it as a new report.
Comment 4 Heiko Tietze 2020-06-19 15:35:05 UTC
(In reply to Buovjaga from comment #3)
> > 1. Draw and Drop of figures, shapes, etc. 
> Currently, you can directly add shapes into the document by Ctrl-clicking
> them in the Drawing toolbar. This does not work with the Sidebar Shapes
> deck.

Don't see much benefit from drag and drop of shape icons into shape objects onto the canvas. Click and drop is actually easier than click, hold, and drop.

Do you agree, Prabesh?
Comment 5 Prabesh432@gmail.com 2020-06-21 03:22:47 UTC
(In reply to Heiko Tietze from comment #4)
> (In reply to Buovjaga from comment #3)
 
> Do you agree, Prabesh?

All I know it, what we can do from that simple website > what we can do from Libre Draw. It's easy & fast from my point of view.

I wish Libre Draw >= that website.

I wish Libre Draw to be more dynamic and very straight forward.

Currently, Libre Draw is not in that state.

(Sorry, I if hurt someone's feelings. I do love LibreOffice as in whole.)
Comment 6 Heiko Tietze 2020-06-22 04:56:55 UTC
You didn't hurt anyone's feeling. We just have to balance benefit of an enhancement with effort of implementation. Plus, potential side-effects for other workflows. Much of your input is covered in other tickets and the drag 'n drop is a wontfix. Your input is very much welcome anyway.