Download it now!
Bug 132025 - macOS: Can't Save As after installing language pack on Catalina
Summary: macOS: Can't Save As after installing language pack on Catalina
Status: RESOLVED DUPLICATE of bug 128233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 132299 (view as bug list)
Depends on: 129177 129178
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2020-04-10 15:30 UTC by eisa01
Modified: 2020-10-29 21:38 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
screencapture demonstrating saving with LO main + installed langpack (German) (8.92 MB, video/mp4)
2020-05-22 18:58 UTC, Christian Lohmaier
Details
screenshot showing notarization message, permission prompt when saving to desktop the first time (398.13 KB, image/png)
2020-05-22 19:18 UTC, Christian Lohmaier
Details
Screenshots showing installation flow (4.19 MB, application/pdf)
2020-05-23 08:08 UTC, eisa01
Details
Screen recording of Save as fails (18.89 MB, video/quicktime)
2020-05-23 08:11 UTC, eisa01
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eisa01 2020-04-10 15:30:06 UTC
Description:
After installing a language pack on Catalina you are not able to use the "Save As" dialog.

This occurs on an Admin account

Granting Full Disk Access is a work-around. It may be related to the code signing issue

Steps to Reproduce:
1. Install LO
2. Install LO language pack
3. Try to Save As

Actual Results:
In Console I see:
+[NSXPCSharedListener endpointForReply:withListenerName:]: an error occurred while attempting to obtain endpoint for listener 'com.apple.view-bridge': Connection interrupted
ERROR: Unable to display save panel (unrecognized error: Error Domain=NSCocoaErrorDomain Code=4099 UserInfo={NSDebugDescription=<private>})

Expected Results:
Save As panel shows


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: en-US (en_NO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 eisa01 2020-04-10 15:45:24 UTC
Confirmed by comment #9 on bug 128233

Setting this as highest critical as it can destroy onboarding of non-technical users
Comment 2 Axel Howind 2020-04-12 18:37:22 UTC
This can not only destroy onboarding of non-technical users, this can also drive current (even technical) users away from LO. After the blurry fonts desaster this is already the second time within months that LO has a bug that might drive away users. :-(

If this is new in 6.4.2.2, I think that version should be removed from the download site for MAC users until a fix is available.
Comment 3 eisa01 2020-04-13 06:21:00 UTC
I don't think it's a new issue, but this is the only version I tested.

There have been reports about this in bug 128233 and its duplicates
Comment 4 Xisco Faulí 2020-04-16 14:25:46 UTC
eisa01, Is it a duplicate of bug 126409 ?
Comment 5 eisa01 2020-04-16 14:32:41 UTC
It may be a prerequisite that bug 126409 is fixed.

But as long as the Language pack installer modifies the app-bundle as in bug 93331, we may still have this problem

There is a proposal in bug 129177 to move language packs into extensions, not sure if that would fix it, or if there is another workaround

I created this new bug so it would be easier to track the consequences of the code-signing issues as there were a lot of duplicates and comments mentioning different save as issues.

This may technically be a duplicate of bug 93331, but now with more serious consequences on Catalina
Comment 6 eisa01 2020-04-25 11:51:34 UTC
*** Bug 132299 has been marked as a duplicate of this bug. ***
Comment 7 Christian Lohmaier 2020-05-22 18:58:46 UTC
Created attachment 161163 [details]
screencapture demonstrating saving with LO main + installed langpack (German)

cannot reproduce. This is on a fresh installation of Catalina.

not shown in the screencap: 
* download dmg for main installer and langpack with Safari
* open main installer and drag the .app to ~/langtest
* start LO → prompt about it being downloaded from the internet and that Apple checked it and didn't find any malware → working notarization
* LO opens in English → close it
* open dmg for langpack and start installation by double-click → finds LO with no issues, and all I have to do is click next, langpack gets installed.
* open LO again → now starts in German.
* document creation works, in Documents folder without any prompt.
* trying to save as to Desktop ("Schreibtisch" in German version of macOS) I get the prompt whether I want allow LO to access the folder, I answer yes and can save.

shown in the screencap:
* mac systeminfo
* launching LO (in German) and showing about-version
* creating new file, using plain save
* using save-as to write to same dir with different name
* using save-as to write to different folder
  (both for writer and calc)
* close LO and restart to create a new session (and check that they still show up in recent documents view)
* open the document and do a save as again like before
* showing the Folders in Finder to show that the files have actually been created...
Comment 8 Christian Lohmaier 2020-05-22 19:18:37 UTC
Created attachment 161164 [details]
screenshot showing notarization message,  permission prompt when saving to desktop the first time

a combined screenshot of the installation steps.

* First-launch confirmation prompts with notarization message ("Apple hat sie auf Malware überprüft und keine gefunden" - Apple checked it for malware and didn't find any) for main LO as well as for langpack-installer
* Languagepack installation in desired language, no issues whatsoever
* macOS permission prompt when first trying to save to Desktop ("Schreibtisch")
Comment 9 eisa01 2020-05-23 07:17:46 UTC
I believe I did not launch LO between the steps "Install LO" and "Install LO language pack"

I don't have my Catalina SSD in my MBP currently
Comment 10 eisa01 2020-05-23 08:08:35 UTC
Created attachment 161180 [details]
Screenshots showing installation flow
Comment 11 eisa01 2020-05-23 08:11:42 UTC
Created attachment 161181 [details]
Screen recording of Save as fails
Comment 12 eisa01 2020-05-23 08:16:09 UTC
Ok, I switched the SSD so I have Catalina

Fresh admin accounts, LO uninstalled from previous testing. Restarted twice

I still have this problem (and I'm not the only one as there's been multiple bug reports about this being broken)

Open dmg, let it verify
Install LibreOffice to /Applications
Install LO language pack (German)
LibreOffice opens during installation
Observe German is not a choice in user preferences
Quit LO
Open LO
Switch to German language in preferences
Restart LO to make it effective
Create a new document and start typing
Choose save as
Observe no saving possible (I get the beach ball, but that is not recorded by the screen recording)

Compared to your steps I see two possible differences:
Installation into user directory
Launching LO before installation (although this is done during installation anyway?)
Comment 13 eisa01 2020-05-23 08:52:41 UTC
Debugging further:

Try the same in ~: Saving not possible

Try launching LO and quitting before installing lang pack in ~Documets: Saving not possible

Install LO to /Applications, Open, Save a document, quit, install language pack: Saving still not possible. Continuing by running codesign -vvv --deep --strict LibreOffice.app, savings starts to be possible (complains about python, then aborts). Persists after LO restart

I have no clue what's going on here, but something is broken :)

Version: 6.4.4.2
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: en-US (en_NO.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 14 Emir Sarı 2020-06-07 13:19:00 UTC
Does anyone plan to take action on this one? This is really silly. It's not like the solution is hard to implement, you just have to bundle localisations in the app bundle as all other macOS applications do.

Or just create a package installer which will allow selecting language packs.

This is just ignoring the situation, ignoring the situation will not solve it by itself.

Hello?! Anyone there??
Comment 15 cpohle 2020-07-02 20:59:54 UTC
Maybe running

    codesign -vvv --deep --strict LibreOffice.app

automatically by the language pack installer would solve the problem?
Comment 16 cpohle 2020-07-15 06:20:43 UTC
>     codesign -vvv --deep --strict LibreOffice.app

I can confirm this works after installing LO 7.0 RC.
Comment 17 Timur 2020-07-16 06:40:13 UTC
*** Bug 134547 has been marked as a duplicate of this bug. ***
Comment 18 Alex Thurgood 2020-07-17 07:13:34 UTC
I would set this as a DUP of bug 128233
Comment 19 steve -_- 2020-07-22 13:53:34 UTC

*** This bug has been marked as a duplicate of bug 128233 ***
Comment 20 Telesto 2020-08-06 08:24:23 UTC
*** Bug 135481 has been marked as a duplicate of this bug. ***