Bug 132239 - Dark Theme doesn't spread to rest of platform when I open in a small window and stretch to bigger window
Summary: Dark Theme doesn't spread to rest of platform when I open in a small window a...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 132756 (view as bug list)
Depends on:
Blocks: LibreOffice-Themes
  Show dependency treegraph
 
Reported: 2020-04-18 19:04 UTC by patricia.p.dimaandal
Modified: 2022-05-12 06:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Supplemental images for the steps provided in bug report. (332.23 KB, image/jpeg)
2020-04-18 19:12 UTC, patricia.p.dimaandal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description patricia.p.dimaandal 2020-04-18 19:04:15 UTC
Description:
The toolbar's dark mode just doesn't stretch with the window - it only goes with the first size the window appears in. If I stretch the window out to fullsize, the toolbar dark theme won't go with it.

Steps to Reproduce:
1. Open LibreOffice Writer in minimum sized window
2. Stretch LibreOffice Writer window to a bigger size

Actual Results:
The toolbar's background stays the same size as the first window it was opened in. 

Expected Results:
I expected the toolbar's background to stretch with the window.


Reproducible: Always


User Profile Reset: No



Additional Info:
It's fine if I open in fullsized window first then minimize. It's a minor inconvenience, but it can make it difficult to see icons.
Comment 1 patricia.p.dimaandal 2020-04-18 19:12:05 UTC
Created attachment 159691 [details]
Supplemental images for the steps provided in bug report.
Comment 2 Dieter 2020-05-07 11:43:28 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)Build ID: 8c8b3a4f83f67882b284ddc3b3fe10d3fe6dedf4CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; Locale: de-DE (de_DE); UI-Language: en-GBCalc: CL

anmd also with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 3 Dieter 2020-05-10 14:25:44 UTC
*** Bug 132756 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2022-05-11 03:33:13 UTC Comment hidden (obsolete)
Comment 5 Dieter 2022-05-12 06:31:25 UTC
WORKSFORME with

Version: 7.3.3.2 (x64) / LibreOffice Community
Build ID: d1d0ea68f081ee2800a922cac8f79445e4603348
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Additonal information:
Dark Theme = Tools -> Options -> Personalisation -> Dark Theme