Bug 132276 - Undo doesn't work properly for moving an image/frame
Summary: Undo doesn't work properly for moving an image/frame
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2020-04-20 14:45 UTC by Telesto
Modified: 2020-08-02 11:02 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-04-20 14:45:36 UTC
Description:
Undo doesn't work properly for moving an image/frame

Steps to Reproduce:
1. Open https://bz.apache.org/ooo/attachment.cgi?id=77417 (bug https://bz.apache.org/ooo/show_bug.cgi?id=65401)
2. Move the top frame/text (or what is it?) on page 1 and 2 to the right border
3. Press CTRL+Z twice

Actual Results:
Image on page 1 "disappears"

Expected Results:
Shouldn't happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4475bcd83aac7e033fc5250f268eb922bd471e7b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Octavian Vladut 2020-05-16 15:29:03 UTC
Atempted to repro in the following build in order to find out where does the image "dissapear.

Version: 7.0.0.0.alpha1 (x64)
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win; 
Locale: en-US (en_US); UI: en-US
Calc: threaded

I used the same file that was provided on step 1.
Steps:
1. Zoom out in order to have a better view on more pages at the same time.
2. Leave the first image from the first page alone.
3. Drag any image from the 2nd page to the 3rd page
4. Press Ctrl + Z

Actual results: The first image from the 1st page jumps on another page.

I also used another file that had less anchors in order to not interact with one another and the "jumping" did not occur.

Based on these I'd say the image jumps due to the interactions of the anchors

Would you be able to confirm the above use case and outcome?
Comment 2 Solar Power Earth 2020-06-02 12:01:11 UTC Comment hidden (spam)
Comment 3 Telesto 2020-08-02 11:02:24 UTC
Looks fine to me
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: ru-RU (nl_NL); UI: en-US
Calc: CL