Download it now!
Bug 132295 - feature request: when cursor is in last line of the document, jump cursor to the last character of the line when pressing arrow-down key on the keyboard.
Summary: feature request: when cursor is in last line of the document, jump cursor to ...
Status: RESOLVED DUPLICATE of bug 83712
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2020-04-21 10:32 UTC by Dan
Modified: 2020-04-28 06:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2020-04-21 10:32:51 UTC
Description:
When the cursor is in last line of the document, it would be nice that when pressing arrow-down key on the keyboard the cursor jumps to the last character of the line. (a feature that word-processors of other companies already have)

Steps to Reproduce:
1. have a text with several lines
2. move cursor to somewhere in center of document
3. press arrow down key several times

Actual Results:
cursor is somewhere in center of last line.

Expected Results:
cursor should be behind the last character in the last line.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.3.2 (x64)
Build-ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU-Threads: 12; BS: Windows 10.0 Build 18363; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 1 Dieter 2020-04-27 10:15:49 UTC
Worksforme with

Version: 7.0.0.0.alpha0+ (x64)Build ID: 8c8b3a4f83f67882b284ddc3b3fe10d3fe6dedf4CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; Locale: de-DE (de_DE); UI-Language: en-GBCalc: CL


To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present.
Comment 2 Dan 2020-04-27 18:31:25 UTC
Well, I tried the LibreOffice-"safemode", hope that is what you meant. My 6.4.3.2 still affected in that case.
Comment 3 Dieter 2020-04-28 06:51:20 UTC

*** This bug has been marked as a duplicate of bug 83712 ***