Download it now!
Bug 132313 - Unable to control table formatting in Writer
Summary: Unable to control table formatting in Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2020-04-21 20:43 UTC by Ian
Modified: 2020-05-04 09:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 2020-04-21 20:43:21 UTC
Description:
Even though I have set for fonts other than Liberation Serif in Preferences and also the template(s) I load (for default text, table contents etc.) when creating a new table with default styling Liberation Sans always comes up.   

Steps to Reproduce:
1.Create table - don't alter any pre-set style settings (=Default).  Fonts will be Liberation Serif despite my own preference and Template font settings being different.
2.I can force my desired style settings by applying the styles.
3.Pressing tab into a new row forces these styles to be reverted to the ones on creation.

Actual Results:
My tables contents font style keeps reverting to Liberation Serif.

Expected Results:
My implemented styles remain in place


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: safemode
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
See this question: https://ask.libreoffice.org/en/question/239801/why-are-tables-always-formatted-with-liberation-sans-font-when-created/

(Actually I'm pretty sure the OS is 64 bit as Catalina is unable to support 32 bit applications.)

Version: 6.3.5.2
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Then I tried just using the icon in the toolbar, and this resulted in my font styles being incorporated into the table as desired.  At the foot of the window 'Default Style' is shown.  So there seems to be a difference between the icon and menu implementations of insert table.
Comment 1 Dieter 2020-04-27 10:26:46 UTC
I can't confirm it with

Version: 7.0.0.0.alpha0+ (x64)Build ID: 8c8b3a4f83f67882b284ddc3b3fe10d3fe6dedf4CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; Locale: de-DE (de_DE); UI-Language: en-GBCalc: CL

I've changed font in Paragraph Style "Table Content" to Arial and inserted a table. Font is Arial.

Does this information solve your problem?
=> NEEDINFO

If it diesn't solve your problem, please add some detailed steps how you've changed your font settings. Thanks
Comment 2 Ian 2020-04-28 07:10:33 UTC
Hello Dieter, thanks for attending to this bug report.

What method did you use to create the table?

As I write at the end of my bug report, when using the toolbar icon button things happen as I would hope - my table content styles are in accordance with the template in use.  

The bug occurs when inserting as table using the menu option.  (Perhaps I did not make this 100% clear; not least because until looking into this I always used the menu option.)  Through this method one is forced to select an overall Style.  Using the pre-highlighted 'Default' gives me Liberation Serif font in all rows.  



(In reply to Dieter from comment #1)
> I can't confirm it with
> 
> Version: 7.0.0.0.alpha0+ (x64)Build ID:
> 8c8b3a4f83f67882b284ddc3b3fe10d3fe6dedf4CPU threads: 4; OS: Windows 10.0
> Build 18363; UI render: Skia/Raster; VCL: win; Locale: de-DE (de_DE);
> UI-Language: en-GBCalc: CL
> 
> I've changed font in Paragraph Style "Table Content" to Arial and inserted a
> table. Font is Arial.
> 
> Does this information solve your problem?
> => NEEDINFO
> 
> If it diesn't solve your problem, please add some detailed steps how you've
> changed your font settings. Thanks
Comment 3 Dieter 2020-04-28 08:40:02 UTC
Results with Table => Insert:

1. Set Paragraph Style "Table Content" to Arial

2a. Table => Insert Table => Style "None" (this is pre-highlighted)
Result: Font is Arial

2b. Table => Insert Table => Style "Default Table Style"
Result: Font is Liberation Serif, although the paragraph style "Table Content" still has font Arial

Ian, do you get the same results?
Comment 4 Ian 2020-04-28 08:52:44 UTC
(In reply to Dieter from comment #3)

Yes, I get the same results.

(For me 'Default Style' is pre-highlighted rather than 'None'; but I followed your selections of None at 2a and Default at 2b.)


> Results with Table => Insert:
> 
> 1. Set Paragraph Style "Table Content" to Arial
> 
> 2a. Table => Insert Table => Style "None" (this is pre-highlighted)
> Result: Font is Arial
> 
> 2b. Table => Insert Table => Style "Default Table Style"
> Result: Font is Liberation Serif, although the paragraph style "Table
> Content" still has font Arial
> 
> Ian, do you get the same results?
Comment 5 Ian 2020-04-28 08:55:02 UTC
What is interesting is that today I was not able to reproduce the effect at Step 3 in my original bug report when using Default Style

i.e. Pressing tab into a new row forces these styles to be reverted to the ones on creation.  Once I had changed the para styles these continued as I pressed tab for new rows.  Strange.
Comment 6 Dieter 2020-04-28 09:06:31 UTC
(In reply to Ian from comment #4)
> (In reply to Dieter from comment #3)
> 
> Yes, I get the same results.

I don't know, if this is the expected result (because it's a pre-defined style) or not. Adding Design-Team for further input and decision.

Related to bug 121023 (perhaps a duplicate), but final discussion in bug 121023 is no very clear to me.
Comment 7 Heiko Tietze 2020-05-04 09:55:30 UTC
Table styles are stored in binary files (bug 49437) which made it impossible to leave properties out. That's why we had to choose a font. 
We have different workflows and unfortunately also different functions to insert a table (cannot find the right ticket but there is one). With the toolbar icon you get a floating wizard and the inserted table has no dedicated style. Using Table > Insert Table it will receive a style, however, and unless you pick None from the list. Besides you can create your own table style (use the sidebar Styles & Formatting, Table Styles are the right-most option at top, use the "New from selection" at the top-right "Styles Actions".

Although these are rather workarounds the intended functionality is there. And many bugs have been filed around this topic. So resolving this as WFM.