Bug 132364 - FILEOPEN DOCX Not all images are printed.
Summary: FILEOPEN DOCX Not all images are printed.
Status: RESOLVED DUPLICATE of bug 129085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-04-23 20:54 UTC by Regina Henschel
Modified: 2020-11-12 08:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original file (602.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-04-23 20:54 UTC, Regina Henschel
Details
File as saved by the user (316.43 KB, application/vnd.oasis.opendocument.text)
2020-04-23 20:55 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-04-23 20:54:47 UTC
Created attachment 159873 [details]
Original file

Open attached document.
Goto File > Print and look at the Print preview.
Some images are missing.

I have got a version too, where the user has saved the document to odt. In that file I see, that all images, which have got style "fr1" will be printed, but all images, which have got style "fr2", "fr3" and "fr4" will not print.

I don't know, why same images have got a different style.

There is no formal difference between the styles. Therefore all images should be printed, regardless of the assigned style.

I have checked, that all images have property printable on.
Comment 1 Regina Henschel 2020-04-23 20:55:27 UTC
Created attachment 159874 [details]
File as saved by the user
Comment 2 Telesto 2020-04-24 16:05:00 UTC
Repro with
Version: 7.0.0.0.alpha0+ (x64)Build ID: 8c8b3a4f83f67882b284ddc3b3fe10d3fe6dedf4CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; Locale: nl-NL (nl_NL); UI-Language: en-USCalc: CL

no repro with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 3 Telesto 2020-04-24 16:14:40 UTC
No repro with
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: 

Repro with
Versie: 6.1.6.3
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: GL; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 raal 2020-04-24 17:12:37 UTC
This seems to have begun at the below commit.
Adding Cc: to Armin Le Grand ; Could you possibly take a look at this one?
Thanks
 92c85798886a96de007558faf66731d064521ac9 is the first bad commit
commit 92c85798886a96de007558faf66731d064521ac9
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Apr 2 21:08:26 2019 +0200

    source 362c1cf2bd580f6dc8bf27bdcd79174111bc1b5c

author	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-02 17:59:40 +0200
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-02 21:03:07 +0200
commit 362c1cf2bd580f6dc8bf27bdcd79174111bc1b5c (patch)
tree 3fae3016fd6960121f40c2391f252e2a94377e21
parent 958442c89237eece4ff2467a7800bca6b0be9fe7 (diff)
tdf#124272 use ClipRegion's geometry if not a rectangle
Comment 5 Timur 2020-05-18 07:20:48 UTC
Same commit and description in bug 129085. I don't see why CC, I'll mark duplicate.

*** This bug has been marked as a duplicate of bug 129085 ***