Download it now!
Bug 132391 - FILEOPEN PPTX: text box not shown
Summary: FILEOPEN PPTX: text box not shown
Status: RESOLVED DUPLICATE of bug 132282
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2020-04-24 22:32 UTC by Gerald Pfeifer
Modified: 2020-04-28 12:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPTX document (1.01 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-04-24 22:32 UTC, Gerald Pfeifer
Details
How it looks like - text box at the top is missing (6.54 KB, image/png)
2020-04-24 22:33 UTC, Gerald Pfeifer
Details
How it should look like (and does in LO 6.4 and Office 365) (30.65 KB, image/png)
2020-04-24 22:33 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-04-24 22:32:22 UTC
Created attachment 159911 [details]
Sample PPTX document

.This is a regression in 

  Version: 7.0.0.0.alpha0+
  Build ID: 2e9261415006ce782a7ae699c69f5be3cec29dff
  CPU threads: 4; OS: Linux 5.6; UI render: default; VCL: gtk3; 
  TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-04-22_02:33:36

versus LibreOffice 6.4.3.2.

Open the sample document in LO 6.4 or Office 365 there is a textbox above
the blue bar.  In LO 7 alpha this is missing.
Comment 1 Gerald Pfeifer 2020-04-24 22:33:08 UTC
Created attachment 159912 [details]
How it looks like - text box at the top is missing
Comment 2 Gerald Pfeifer 2020-04-24 22:33:44 UTC
Created attachment 159913 [details]
How it should look like (and does in LO 6.4 and Office 365)
Comment 3 Aron Budea 2020-04-26 06:01:07 UTC
Confirmed in LO 7.0.0.0.alpha0+ (f924658e45f256544e43c3fdb2af9b585d0f0933) / Ubuntu.

This deteriorated in two steps. After the first commit the text from the top text box showed up in the blue text box, and after the second commit it wasn't shown anymore at all.
The first commit is the same as identified in bug 132282. Adding CC: do nd101 and Serge Krot.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=69b83dc2d3014dd9b18402534e15c937dc082464
author		nd101 <Fong@nd.com.cn>	2020-03-25 13:17:48 +0800
committer	Michael Stahl <michael.stahl@cib.de>	2020-04-01 10:20:26 +0200

"tdf#131554 placeholder iteration fails to stop when a match is found"

https://cgit.freedesktop.org/libreoffice/core/commit/?id=912217285b3058efa54c2336f91fda4efdad6ff0
author		Serge Krot <Serge.Krot@cib.de>	2020-04-10 20:08:37 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2020-04-20 22:17:42 +0200

"tdf#119187 fix: Top-aligned text in PPTX becomes bottom-aligned"
Comment 4 Xisco Faulí 2020-04-28 12:43:22 UTC

*** This bug has been marked as a duplicate of bug 132282 ***