Bug 132400 - Smooth fade transition not working in LibreOffice Impress
Summary: Smooth fade transition not working in LibreOffice Impress
Status: RESOLVED DUPLICATE of bug 91456
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-25 13:27 UTC by Joe
Modified: 2022-08-08 15:58 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe 2020-04-25 13:27:24 UTC
Description:
Smooth fade transition not working well in Impress, either flashes/flickers black and next slide appears.

Steps to Reproduce:
1.Create two different slides in Impress
2.Add a "fade" transition, change from "black" to smooth
3.Start slideshow from first slide, advance to next slide

Actual Results:
Screen either turns black or flashes black and next slide 'appears' during transition from slide to slide

Expected Results:
One slide fades gradually into another


Reproducible: Always


User Profile Reset: No



Additional Info:
I have tested this across MULTIPLE versions of LibreOffice, MULTIPLE Operating systems (various Linux distros and even Windows), and MULTIPLE styles of graphics hardware (Nvidia GT/GTX, AMD A series graphics). The effect varies but the desired effect never happens as it should.
Comment 1 V Stuart Foote 2020-04-25 15:59:23 UTC
Can not confirm on Windows 10 Home 64-bit en-US (1909)
Intel HD Graphic 620 GPU with
2020-04-25 TB77 build of master
Version: 7.0.0.0.alpha0+ (x64)
Build ID: fe1cf8656d6963844553993a77ef565fb2fbeda7
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

The "Fade" transition, both 'Through black' and 'Smoothly' render a smooth incremental transition from one slide image to the next. The 'Through black' or 'Smoothly' effects fade out the first slide, while fading in the second slide.

Isolation of the two slide images is increased by lengthening the duration (from default 2.0 sec to 4.0 sec worked well).

Transition rendered as expected in all graphics modes:
CPU only
CPU w/HA
OpenGL rendering
Skia Vulkan rendering
Skia raster rendering
Comment 2 Timur 2020-04-25 18:19:54 UTC
Rule of thumb is search before reporting. And this looks like a known issue.

*** This bug has been marked as a duplicate of bug 91456 ***