Bug 132502 - FILEOPEN: DOCX: Grouped shape containing arrows rotated
Summary: FILEOPEN: DOCX: Grouped shape containing arrows rotated
Status: VERIFIED DUPLICATE of bug 122717
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Grouped-Shapes
  Show dependency treegraph
 
Reported: 2020-04-28 19:36 UTC by Rhys Young
Modified: 2021-06-10 10:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Normal graphs (34.98 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-04-28 19:37 UTC, Rhys Young
Details
Rotated graphs pdf (18.42 KB, application/pdf)
2020-04-28 19:37 UTC, Rhys Young
Details
Comparison MSO 2010 and LibreOffice 7.0 master (66.04 KB, image/png)
2020-05-13 10:42 UTC, Xisco Faulí
Details
The example file opened in Word and current Writer (141.07 KB, image/png)
2020-08-31 14:28 UTC, NISZ LibreOffice Team
Details
Example file minimized and with 4 rotation values (54.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-09-25 06:30 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rhys Young 2020-04-28 19:36:19 UTC
Description:
When converting a word document to a PDF the PDF does has rotated versions of the graphs.

Steps to Reproduce:
Steps to Reproduce:
1. Convert file to PDF using 'soffice --headless --nolockcheck --nodefault --nofirststartwizard --nologo --norestore --convert-to pdf --outdir /tmp /tmp/test.docx'
2. Open PDF using a viewer
3. Observe the graphs are rotated

Actual Results:
Graphs should be in proper orientation

Expected Results:
Graphs are not in proper orientation


Reproducible: Always


User Profile Reset: No



Additional Info:
None
Comment 1 Rhys Young 2020-04-28 19:37:11 UTC
Created attachment 160042 [details]
Normal graphs
Comment 2 Rhys Young 2020-04-28 19:37:50 UTC
Created attachment 160043 [details]
Rotated graphs pdf
Comment 3 Xisco Faulí 2020-05-13 10:42:15 UTC
This is a docx import issue

Version: 7.0.0.0.alpha1+
Build ID: 1ffe59ef31186e36ad0aa7bbcdd32e407ee8d26c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Xisco Faulí 2020-05-13 10:42:34 UTC
Created attachment 160747 [details]
Comparison MSO 2010 and LibreOffice 7.0 master
Comment 5 Xisco Faulí 2020-05-13 10:43:33 UTC
Also reproduced in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 6 Xisco Faulí 2020-05-13 10:45:02 UTC
@NISZ, I thought your team might be interested in this issue after Szabolcs' related to arrows
Comment 7 NISZ LibreOffice Team 2020-05-13 14:15:32 UTC
Looks like the grouped shape that contains the charts gets some unexpected rotation value.
Comment 8 NISZ LibreOffice Team 2020-08-31 14:28:43 UTC
Created attachment 164926 [details]
The example file opened in Word and current Writer

The grouped shape gets 270 degrees rotation value instead of 0. 
Resetting to 0 manually restores the original look of the document.
Comment 9 NISZ LibreOffice Team 2020-09-25 06:30:10 UTC
Created attachment 165823 [details]
Example file minimized and with 4 rotation values

After changing the example file to contain the object rotated:

0 degrees is imported as 270 - looks different
90 degrees is imported as 180 - looks the same
180 degrees is imported as 90 - looks different
270 degrees is imported as 0 - looks the same
Comment 10 Regina Henschel 2021-05-09 22:03:39 UTC
I see no difference to Word using (3.May) Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9c930c4f3109d123c0831d0fcecf9c8b32e5bbc7
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL
Comment 11 Xisco Faulí 2021-05-10 08:33:07 UTC
Yes, it's fixed in master. Issue fixed by

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3e4eb070787d4d44b3bdc95046e5b231dbbef42b

author	Xisco Fauli <xiscofauli@libreoffice.org>	2021-03-25 17:38:20 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2021-03-26 09:10:17 +0100
commit 3e4eb070787d4d44b3bdc95046e5b231dbbef42b (patch)
tree 185ec85a2454dcc8ac0428c38fa8b3f76d61d308
parent 1fcc08d5dccaf8280fa7709df6eb310b8f502fb2 (diff)
tdf#122717: fix handling of zero width/height lines

Closing as dupe of bug 122717

*** This bug has been marked as a duplicate of bug 122717 ***
Comment 12 NISZ LibreOffice Team 2021-06-10 10:08:17 UTC
Verified in:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: aa9cb8e14749e7fb7a83b55a2bb095501f731a18
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded