Bug 132550 - PDF: Viewer opens too soon before PDF is exported.
Summary: PDF: Viewer opens too soon before PDF is exported.
Status: RESOLVED DUPLICATE of bug 120343
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-30 10:01 UTC by HansPL
Modified: 2020-05-14 20:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description HansPL 2020-04-30 10:01:55 UTC
Description:
I have set the LO option Load/Save, General, Edit doc properties before saving 
and for PDF export “View PDF after export“.  
When exporting a PDF, the doc properties dialog also opens and the PDF viewer is opened at the same time, *before* I have OKed the properties and thus exported the PDF.  

Steps to Reproduce:
1. Open a document, set options to edit document properties before saving and to view PDF after export. 
2. Export it to PDF (does not exist yet).  
3. Doc properties dialog opens.  
4. Click OK — the PDF is generated but not opened.  
5. Export it again, Yes to overwrite. 
6. The *old* PDF is opened and the doc properties dialog opens.
7. Click OK —  now it depends on the viewer and the file system whether the PDF is overwritten and its view refreshed, or the PDF cannot be overwritten.  

Actual Results:
The PDF viewer is started before actually exporting, while the doc properties dialog is still open.

Expected Results:
The PDF viewer should be started only after the doc properties dialog is closed and the PDF is actually exported.


Reproducible: Always


User Profile Reset: No



Additional Info:
This bug was not present in older LO versions.
Comment 1 Aron Budea 2020-05-14 20:30:30 UTC
This looks like a duplicate of bug 120343, and should be fixed. Please try with a more recent version.

*** This bug has been marked as a duplicate of bug 120343 ***