Download it now!
Bug 132554 - 'freeze first row' does not work when the first row is not on the screen
Summary: 'freeze first row' does not work when the first row is not on the screen
Status: RESOLVED DUPLICATE of bug 100666
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-30 10:53 UTC by Andrej Kvasnica
Modified: 2020-05-11 14:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Kvasnica 2020-04-30 10:53:39 UTC
My screen shows spreadsheet with 45 rows.

When there is row 1 shown and I move cursor to any row of 1..45 and choose '/view/freeze cells/freeze first row' from the menu the first row is freezed which is OK.

When I move cursor to row 46 (so the screen shows rows 2..46) and choose '/view/freeze cells/freeze first row' nothing is freezed which is not OK.
This behaviour is not related to any spreadsheet content (works this way on new spreadsheet too).

This bug seems to be unrelated to cursor position. It's sufficient to leave cursor on row 1 and scroll the spreadsheet down few pages and select 'freeze first row' to show this error too.

Also having cursor on row 100 and showing rows 1..45 on the screen just works fine - the first row is freezed.
Comment 1 Andrej Kvasnica 2020-05-05 11:40:48 UTC
same behaviour in latest 6.4.3.2 release
Comment 2 Andrej Kvasnica 2020-05-11 14:41:43 UTC
same behaviour in latest 7.0.0.0.alpha1 build 6a03
Comment 3 Xisco Faulí 2020-05-11 14:46:17 UTC
Thanks for reporting this issue.
Dupe of bug 100666

*** This bug has been marked as a duplicate of bug 100666 ***