Download it now!
Bug 132639 - Tooltips randomly pop-up when LibreOffice is in second plane / minimized [kf5 VCL only]
Summary: Tooltips randomly pop-up when LibreOffice is in second plane / minimized [kf5...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-05-03 13:25 UTC by RGB
Modified: 2020-11-19 11:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice tooltip appearing at a random position in the screen (10.62 KB, image/png)
2020-05-03 13:25 UTC, RGB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2020-05-03 13:25:49 UTC
Created attachment 160276 [details]
LibreOffice tooltip appearing at a random position in the screen

Version 6.4.2.2 with kf5 VCL plug-in, openSUSE Leap 15.1. 

When LibreOffice is in second plane or even minimized, tooltips pop-up randomly in my screen, as you can see in the attached screenshot I took while browsing in firefox with LibreOffice Writer minimized in the taskbar (the tooltip is for the "insert special characters" button, in Spanish). 

This does not happen with the GTK plug-in, nor with any other application, only with LibreOffice and only with the kf5 plug-in. It seems LibreOffice keep sending signals to the desktop even when it is not in focus. 

I failed to find what may trigger the behavior. The tooltips just appear at random times and at random positions.
Comment 1 Ming Hua 2020-05-04 02:39:35 UTC
Let's ping the KDE people to see what they can do.
Comment 2 Michael Weghorn 2020-05-04 07:09:36 UTC
I haven't experienced this so far, can you please retest whether this still happens with a current daily build, as available at [1]?
You can install that in parallel as described at [2].

If it still happens, it would be great if you could find out a bit more about when this happens (how to trigger the behaviour), since it's very hard to analyse an issue you cannot reproduce.

[1] https://dev-builds.libreoffice.org/daily/master/current.html
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 3 Michael Weghorn 2020-05-04 07:10:38 UTC
Also, have you seen a similar behaviour for any other application than LibreOffice as well?
Comment 4 RGB 2020-05-04 13:23:34 UTC
@ Michael Weghorn, 

> can you please retest whether this still happens with a current daily build

Yes, it still happens with 7.0 alpha. At least one of the times it happened immediately after Writer did the autorecovery operation, but I don't know if it was a coincidence. 

> have you seen a similar behaviour for any other application than LibreOffice as well?

No, only LibreOffice and only with kf5 plug-in.
Comment 5 Michael Weghorn 2020-05-04 13:37:23 UTC
OK, thanks. In case you find out more, please mention it here. Otherwise, let's see if anybody else might have another idea...
Comment 6 Michael Weghorn 2020-05-04 13:39:36 UTC
Just to be sure: Is this in a Plasma session or is another desktop environment in use? Is this running on X11 or Wayland?
Comment 7 RGB 2020-05-04 13:45:21 UTC
(In reply to Michael Weghorn from comment #6)
> Just to be sure: Is this in a Plasma session or is another desktop
> environment in use? Is this running on X11 or Wayland?

Plasma 5.12.8, X11
Comment 8 Xisco Faulí 2020-11-18 15:21:40 UTC
Hello RGB,
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 9 RGB 2020-11-18 23:13:58 UTC
It seems the bug is gone in Version 7.0.3.1. I kept it open for a couple of hours now and did not see the problem.