Download it now!
Bug 132670 - pasting image cut from webpage fails
Summary: pasting image cut from webpage fails
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-04 07:39 UTC by Chris Sleightholme
Modified: 2020-06-10 17:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Sleightholme 2020-05-04 07:39:29 UTC
Description:
I currently have version 6.4.3.2 (x64) installed under Windows 10, but this has existing in previous versions also.

I am unable to paste an image copied from a WEB page into any of the Libre Office applications. I am currently using the "Snip & Sketch" tool to select a portion of a WEB page.

Using the same tool to copy from other applications works fine, only WEB pages seem to cause an issue.

For reference, pasting into other non-Libre Office applications works fine.

This issue is stopping me moving to Libre Office, as without being able to do this simple thing I can't do tasks I need to do. 


Steps to Reproduce:
1.select a range to copy from a WEB page using either Chrome, IE, Edge, Vivaldi browsers 
2.Try to past the selected image into any Libre Office document - it does not work


Actual Results:
Nothing gets pasted

Expected Results:
The copied image should get pasted


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
It does not matter what is being selected/copied in the image, but it only applies to an copied image - selecting text as text ( rather than an image ) from the  web page works fine.
Comment 1 ian 2020-05-05 14:26:04 UTC
Thank you for reporting the bug.

Can you please clarify what you mean by "select a range to copy" in step 1?

I attempted to reproduce the bug (assuming you meant to copy a single image from any web page) using the most recent stable version and a recent master build, and I was unable to do so.

Using:

Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

And:

Version: 7.0.0.0.alpha0+ (x64)
Build ID: b8fb7ecd9cdbe1898c41eaecd9894df8e8f01e25
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 2 Chris Sleightholme 2020-05-05 14:40:32 UTC
Hello,
Thanks for picking this up.
I am trying to select a region of a web page and paste that as an image into a document.
On Windows I use the in-built Snip and Sketch tool.
It is not an image as in a picture, but any part of a web page.

My computer details are :-
Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded
Comment 3 ian 2020-05-06 14:18:57 UTC
Thanks for providing that information.

I can confirm that this isn't working for 6.4.3.2, but it is working for a recent master build.

Using:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: b8fb7ecd9cdbe1898c41eaecd9894df8e8f01e25
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

I do get the image copy and pasted, so there is an issue with the stable build.
Comment 4 Telesto 2020-05-06 14:39:24 UTC
(In reply to ian from comment #3)
> Thanks for providing that information.
> 
> I can confirm that this isn't working for 6.4.3.2, but it is working for a
> recent master build.
> 
> Using:
> Version: 7.0.0.0.alpha0+ (x64)
> Build ID: b8fb7ecd9cdbe1898c41eaecd9894df8e8f01e25
> CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL:
> win; 
> Locale: en-US (en_US); UI-Language: en-US
> Calc: CL
> 
> I do get the image copy and pasted, so there is an issue with the stable
> build.

Site & browser would be nice
Comment 5 Chris Sleightholme 2020-05-06 14:46:41 UTC Comment hidden (obsolete)
Comment 6 Telesto 2020-05-06 15:53:02 UTC
Hmmm, copy paste is working fine when opening this in Vivaldi and pasting it to Writer 6.4.3.2
https://en.wikipedia.org/wiki/Artificial_intelligence#/media/File:Didrachm_Phaistos_obverse_CdM.jpg
Comment 7 ian 2020-05-07 13:36:00 UTC
Providing more information about what worked:

I used Chrome Version 81.0.4044.138 (Official Build) (64-bit) and snipped a text portion of the bug report, https://bugs.documentfoundation.org/show_bug.cgi?id=132670.

I also snipped the "Bug Hunting Session" image present in the heading on every page of bugs.documentfoundation.org.

I couldn't get this to work in 6.4.3.2, but it did work in 7.0.0.0.alpha0+.
Comment 8 Buovjaga 2020-06-09 18:24:57 UTC
Chris: you could install a master build. It installs separately and will not mess with your stable installation: https://dev-builds.libreoffice.org/daily/master/current.html Win-x86_64@tb77-TDF

Let us know, if the problem is gone with it.
Comment 9 Timur 2020-06-10 12:23:34 UTC
I do not reproduce in Windows 7 with Snipping Tool. 
Browser doesn't seem relevant, rather tool does. 

New is not justified so I set NeedInfo.
Telesto set bibisectRequest but without explantion, please do yourself if you reproduce. Until then, I remove bibisectRequest, regression.
Ian, can you do bibisectRequest? Please test with fresh master.
Comment 10 Chris Sleightholme 2020-06-10 17:43:17 UTC
Hello,
Responding to the comment by Buovjaga 2020-06-09 18:24:57 UTC

I installed the version you pointed me to and this works well, so many thanks.
Comment 11 Buovjaga 2020-06-10 17:50:42 UTC
Great, let's close.