Bug 132676 - EDITING Writer hangs when scrolling in particular table
Summary: EDITING Writer hangs when scrolling in particular table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks: DOCX-Tables Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2020-05-04 12:05 UTC by NISZ LibreOffice Team
Modified: 2021-08-05 09:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Word (14.75 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-05-04 12:05 UTC, NISZ LibreOffice Team
Details
Sample DOCX from Word with comments (24.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-05-28 14:28 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-04 12:05:02 UTC
Created attachment 160319 [details]
Example file from Word

Attached user made table has a tendency of hanging for some 10-20 seconds when scrolling past the page breaks.

Steps to reproduce:
    1. Open attached document
    2. Press Page Down / Page Up quickly

Actual results:
When the view is at the page breaks and should show the next page, Writer hangs for some seconds, but continues after a bit of time. Multiple quick keypresses result in more wait. 
Once the pages are scrolled over to the bottom, the problem does not happen again, but if the window loses and then gets back the focus, it does.

Expected results:
Writer should not hang.

LibreOffice details:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 00db5933ded1884b2ac453552badae20fa943478
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

Bibisected using bibisect-win64-6.X to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=c56bf1479cc71d1a2b0639f6383e90c1f7e3655b

author
Miklos Vajna <vmiklos@collabora.com> Mon Sep 16 21:15:28 2019 +0200 
committer
Miklos Vajna <vmiklos@collabora.com> Tue Sep 17 08:57:15 2019 +0200 

tdf#105330 sw: fix lost cursor on undoing nested table insert

Adding CC to: Miklos Vajna
Comment 1 NISZ LibreOffice Team 2020-05-04 12:09:14 UTC
Also: turning off "Page break between rows" in Word stops this from happening.
Comment 2 Miklos Vajna 2020-05-04 15:48:10 UTC
In practice this never worked, though. It "worked" when it had side effects like bug 105330, which is the reason the above commit went back to the original state.
Comment 3 Dieter 2020-05-07 18:59:46 UTC Comment hidden (obsolete)
Comment 4 Telesto 2020-05-07 20:24:56 UTC
(In reply to Dieter from comment #3)
> So it's a bug, but not a regression? So I'm not sure, if I can change status
> to NEW, but I can confirm it with

A hanging document seems wrong to me; NEW it is. Removing the regression part.
Comment 5 Aron Budea 2021-05-28 14:28:47 UTC
Created attachment 172411 [details]
Sample DOCX from Word with comments

Another symptom from this change is that in affected files that have comments, typing into table cells makes the comments flicker.

Attached a modified version of the original sample with a few comments that exhibits this.
Comment 6 NISZ LibreOffice Team 2021-07-21 13:54:56 UTC
This seems to be fixed since:

https://git.libreoffice.org/core/+/a0cd270a99f43049fc099ddd463e57aa243d5b0e

author	Michael Stahl <michael.stahl@allotropia.de>	Fri Jun 25 10:25:59 2021 +0200
committer	Michael Stahl <michael.stahl@allotropia.de>	Fri Jun 25 16:44:32 2021 +0200

sw: layout: fix table split loop caused by RemoveFollowFlowLinePending

Thanks Michael for fixing this one!
Comment 7 NISZ LibreOffice Team 2021-08-05 09:03:39 UTC
Verified in: 

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ad1b12686da88bea57582df10fa85268ada209b8
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded