Download it now!
Bug 132690 - Update filter after change in data
Summary: Update filter after change in data
Status: RESOLVED DUPLICATE of bug 130770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.4.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-04 17:00 UTC by p_kongstad
Modified: 2020-05-17 16:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p_kongstad 2020-05-04 17:00:09 UTC
Description:
If you have made autofilter for a spreadsheet, then after change data in area of the filter, you open the filter, but do not change filtering value, then nothing happens. The filter should always be updating when pressing ok.

Actual Results:
You have to change filtering value and then change back to the value to have the filter reactivated.

Expected Results:
Pressing ok should always filter according to values.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
This is how other software are working as an example Google sheets.
Comment 1 b. 2020-05-17 16:33:04 UTC
hi, 

missing info about version you used, thus not sure answer, but looks as a dup of #130770, #131095, #131612, which are solved for 7.0 ver. 

steps as described work ok (updating filtering without need to touch filter definition) with: 

Version: 7.0.0.0.alpha1 (x64)
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI: en-US
Calc: threaded

setting resolved, pls. reopen if i'm wrong,

*** This bug has been marked as a duplicate of bug 130770 ***