Download it now!
Bug 132702 - CLEAR DIRECT FORMATTING: Wrong information in LO Help
Summary: CLEAR DIRECT FORMATTING: Wrong information in LO Help
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clear-Formatting Help-Changes-Features
  Show dependency treegraph
 
Reported: 2020-05-05 08:12 UTC by Dieter
Modified: 2020-08-30 10:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter 2020-05-05 08:12:59 UTC
Actual information in LO Help about Clear Formatting: "Removes direct formatting and formatting by character styles from the selection" https://help.libreoffice.org/7.0/en-GB/text/shared/01/05010000.html?&DbPAR=WRITER&System=WIN

Information is not correct. Clear formatting removes only direct formatting. (see bug 132469 comment 9.
Comment 1 Timur 2020-07-15 07:41:26 UTC
Please write in a duplicated bug.

*** This bug has been marked as a duplicate of bug 106195 ***
Comment 2 Octavio Alvarez 2020-07-15 14:59:40 UTC
This seems not to be a duplicate of bug 106195 but of bug 132469 instead.

Bug 106195 discusses the impact of the command on the full set of direct formatting attributes on a paragraph, and I quote from there: "But of course it doesn't actually remove _all_ direct formatting."

This bug is about the impact of the command on character styles, and so is 132469. Both, concluding the same thing.

Can this be updated to reflect the best duplicate?
Comment 3 Octavio Alvarez 2020-07-15 15:05:14 UTC
Wait... in bug 132469 it is suggested that a new ticket is opened for this, so *this* is the ticket for the issue. It would not make sense to mark it as duplicate of bug 132469, as I suggested.

I think the resolution is incorrect of this ticket. It should stand on its own to remove the note that the online help says:

> Removes direct formatting from the selection.

instead of 

> Removes direct formatting and formatting by character styles from the selection.

This is because this ticket discusses the impact of Clear Direct Formatting on Character Styles. The other ticket discusses the impact of Clear Direct Formatting on the full set of Direct Formatting attributes to a paragraph.
Comment 4 Timur 2020-07-15 17:26:15 UTC
(In reply to Octavio Alvarez from comment #3)
> This is because this ticket discusses the impact of Clear Direct Formatting
> on Character Styles. The other ticket discusses the impact of Clear Direct
> Formatting on the full set of Direct Formatting attributes to a paragraph.

Too many discussions, comments are not of value. 
Single bug is proper to explain all on Clear Direct Formatting, really no need to split.

With current help and proposed https://bugs.documentfoundation.org/show_bug.cgi?id=106195#c8, feel free to add there full text proposal.
Comment 5 Octavio Alvarez 2020-07-16 15:29:06 UTC
This has been fixed in commit 2ea58f0c0e5270f6cce5f5cb80f054d1f3c37f50: 

https://git.libreoffice.org/help/+/2ea58f0c0e5270f6cce5f5cb80f054d1f3c37f50%5E%21/

Setting this to Fixed and adding 106195 to See Also, so disussion on further improvemets (like inclusion or exclusion of Bullets and Numbering) can continue there.

For now, it is important to remove the false explicit statement that character styles are removed by using Clear Direct Formatting.
Comment 6 Dieter 2020-08-30 10:17:28 UTC
Correct information in help for LO 7.1: https://help.libreoffice.org/7.1/en-GB/text/shared/01/05010000.html?&DbPAR=WRITER&System=WIN

=> VERIFIED FIXED