Bug 132724 - Crash in: BigPtrArray::Index2Block(unsigned __int64) anchor to character
Summary: Crash in: BigPtrArray::Index2Block(unsigned __int64) anchor to character
Status: RESOLVED DUPLICATE of bug 132725
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Anchor-and-Text-Wrap Crash-BigPtrArray Crash
  Show dependency treegraph
 
Reported: 2020-05-05 15:33 UTC by Telesto
Modified: 2020-06-11 09:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["BigPtrArray::Index2Block(unsigned __int64)"]


Attachments
Example file (71.28 KB, application/vnd.oasis.opendocument.text)
2020-05-05 15:33 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-05 15:33:52 UTC
Created attachment 160387 [details]
Example file

This bug was filed from the crash reporting server and is br-bfecfaa8-c6d9-4691-9275-8b627b8803f5.
=========================================

1. Open the attached file
2. Type AA after opening
3. Backspace
4. Backspace
5. CTRL+Z
6. CTRL+Z
7. CTRL+Y
8. CTRL+Y
9. CTRL+Z -> crash

File is anchored to character (no crash with 6.3). However undo slightly odd in 6.3
Comment 1 MM 2020-05-05 17:50:46 UTC
Confirmed on windows 10 x64 with Version: 6.4.4.1 (x64)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Comment 2 Alex Thurgood 2020-05-06 08:17:10 UTC
Also confirmed with Collabora LOVanilla :

Command:          soffice
Path:             /Applications/LibreOffice Vanilla.app/Contents/MacOS/soffice
Identifier:       com.collabora.libreoffice-free
Version:          6.4.3005 (6.4.3005)
App Item ID:      921923693
App External ID:  835730758
Parent:           launchd [1]
PID:              1904
Comment 3 Xisco Faulí 2020-05-06 18:12:19 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2903d85d6197829633d7f96c95cd55821c2c20ff

author	Luboš Luňák <l.lunak@collabora.com>	2014-08-12 18:39:02 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2014-08-12 20:23:16 +0200
commit	2903d85d6197829633d7f96c95cd55821c2c20ff (patch)
tree	c73b28cb073885647e4e9274735bc7e4ed93fa10
parent	95f0811c093680e6258f3bc973a3f7a3731a28f4 (diff)
fix deleting an image anchored to last paragraph in document

Bisected with: bibisect-44max

Adding Cc: to Luboš Luňák
Comment 4 Telesto 2020-05-10 10:36:02 UTC
No crash with tracking changed enabled
Comment 5 Xisco Faulí 2020-06-11 09:03:40 UTC
This issue is fixed by https://git.libreoffice.org/core/commit/32c162ad1723512763b74d01eaec32c1296f3a55

Closing as duplicated of bug 132725

*** This bug has been marked as a duplicate of bug 132725 ***