Bug 132740 - Formatting all comments rather slow
Summary: Formatting all comments rather slow
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2
Keywords: perf
: 143661 (view as bug list)
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2020-05-05 19:48 UTC by Telesto
Modified: 2021-08-08 16:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (20.40 KB, application/vnd.oasis.opendocument.text)
2020-05-05 19:48 UTC, Telesto
Details
monitor (197.36 KB, image/png)
2020-05-17 21:04 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-05 19:48:20 UTC
Description:
Formatting all comments rather slow

Steps to Reproduce:
1. Open the attached file
2. Click on a drop down arrow of the comment box
3. Format all comment
4. Pick a highlighting.. and press OK

Actual Results:
Slow.. 5 seconds

Expected Results:
1 second


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc:
Comment 1 Telesto 2020-05-05 19:48:32 UTC
Created attachment 160403 [details]
Example file
Comment 2 BogdanB 2020-05-17 21:04:14 UTC
Created attachment 160954 [details]
monitor

More then 60 seconds. 2 CPU at 100%
See image

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Linux 5.4; UI render: Skia/Raster; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 3 Commit Notification 2021-07-07 10:07:20 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/73c9ef661d9ef6237d3fd3c259fd040a545b44cf

tdf#132740 don't broadcast if modified status has not changed

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-07-07 10:09:31 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3e942e40a6c175e4e42a16be83191bc5e01f43b9

tdf#132740 improve TagWindowAsModified

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-07-07 11:11:21 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2ca614be3eb65d852b2c811c853b754e5e5ecb36

tdf#132740 bypass work if selection has not changed

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-07-07 15:52:58 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4c76bcb5f35527283c6070fc8e3911a35734eba1

tdf#132740 avoid some WeakReference cost in accessibility

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-07-08 07:23:35 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/865641047be4a693f7a51635ce06eab15675126d

tdf#132740 bypass work if selection has not changed

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-07-08 09:55:00 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/60d35f767781de4b8f1e7b264b12015f655c647d

tdf#132740 don't broadcast if modified status has not changed

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2021-08-04 10:10:12 UTC
*** Bug 143661 has been marked as a duplicate of this bug. ***