Download it now!
Bug 132744 - Images anchored to character in table not pasted
Summary: Images anchored to character in table not pasted
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.5
Keywords: bibisected, bisected, regression
: 132912 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap Writer-Images
  Show dependency treegraph
 
Reported: 2020-05-05 21:03 UTC by Telesto
Modified: 2020-06-17 05:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (474.23 KB, application/vnd.oasis.opendocument.text)
2020-05-05 21:04 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-05 21:03:54 UTC
Description:
Images anchored to character in table not pasted

Steps to Reproduce:
1. Open the attached file
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V

Actual Results:
No paste

Expected Results:
Image should be included


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc:
Comment 1 Telesto 2020-05-05 21:04:08 UTC
Created attachment 160406 [details]
Example file
Comment 2 Timur 2020-05-11 08:24:11 UTC
896e26965e808477374861045bd4a0a2e2aa5698 is the first bad commit
Date:   Tue Apr 14 18:53:17 2020 +0200
    source sha:971205dc2110c1c23ff1db1fc4041e2babf6fa9f

Previous source sha:11785217594d863efb518aa8b8f2910cdcb9c59d.

https://gerrit.libreoffice.org/plugins/gitiles/core/+/971205dc2110c1c23ff1db1fc4041e2babf6fa9f%5E!/

commit	971205dc2110c1c23ff1db1fc4041e2babf6fa9f	[log]
author	Michael Stahl <Michael.Stahl@cib.de>	Thu Apr 09 18:31:50 2020 +0200
committer	Michael Stahl <michael.stahl@cib.de>	Tue Apr 14 16:59:00 2020 +0200
tree	206e18ddc8ee58be806c59ed4e78724550647498
parent	11785217594d863efb518aa8b8f2910cdcb9c59d [diff]

sw: fix fly at-char deletion API behaviour change

Hi Michael, can you please see where the cats are disappearing.
Comment 3 Commit Notification 2020-06-11 17:11:07 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cc4b5091e739116a7ec83513fa1cd856f0130330

tdf#132744 sw: fix subtle difference when checking end of section

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2020-06-11 17:15:43 UTC
fixed on master
Comment 5 Commit Notification 2020-06-11 23:13:51 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/34a6ca0af17deae2a3df141e214f2366955b9d68

tdf#132744 sw: fix subtle difference when checking end of section

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-06-11 23:13:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0d97bcee3505cf70828aaf4f053c079127b7f94d

tdf#132744 sw: fix subtle difference when checking end of section

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-06-12 12:08:42 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: ff508f6d8a3e58d29e9e7622006a7103fb0a2849
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!!
Comment 8 Commit Notification 2020-06-12 15:08:38 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a7b12e23bf9ac8e394405a1de5835e18e40c27c2

tdf#132744: sw: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-06-12 16:44:57 UTC
*** Bug 132912 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2020-06-17 05:58:47 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-5":

https://git.libreoffice.org/core/commit/0e2431fe1d123cad95b6db4604a78b3337aeb7a8

tdf#132744 sw: fix subtle difference when checking end of section

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.