Bug 132755 - No Apple Crash Report after crash when autorecovery dialog kicks in
Summary: No Apple Crash Report after crash when autorecovery dialog kicks in
Status: RESOLVED DUPLICATE of bug 100341
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-06 07:45 UTC by Telesto
Modified: 2020-05-21 07:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-06 07:45:00 UTC
Description:
No Apple Crash Report

Steps to Reproduce:
1. Follow the steps of bug 132724


Actual Results:
Crash & file recovery

Expected Results:
Apple crash report


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.3.2
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: GL; VCL: osx; 
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Alex Thurgood 2020-05-06 08:20:03 UTC
Crash report generated for me with :

Command:          soffice
Path:             /Applications/LibreOffice Vanilla.app/Contents/MacOS/soffice
Identifier:       com.collabora.libreoffice-free
Version:          6.4.3005 (6.4.3005)
App Item ID:      921923693
App External ID:  835730758
Parent:           launchd [1]
PID:              1904


and with 
Command:          soffice
Path:             /Applications/LibreOffice Vanilla.app/Contents/MacOS/soffice
Identifier:       com.collabora.libreoffice-free
Version:          6.4.3005 (6.4.3005)
App Item ID:      921923693
App External ID:  835730758
Parent:           launchd [1]
PID:              1904


after force killing the app, because it hangs when following the steps in bug 132724.
Comment 2 Alex Thurgood 2020-05-06 08:22:02 UTC
Sorry, copy/pasted same version twice, a crash report is also generated for me when I force quit using :

Date/Time:        2020-05-06 10:20:55 +0200
End time:         2020-05-06 10:21:14 +0200
OS Version:       Mac OS X 10.15.4 (Build 19E287)
Architecture:     x86_64h
Report Version:   29

Data Source:      Stackshots
Shared Cache:     0x3eee000 5DD431F6-54FB-399E-A535-8B0F54F7F51F

Command:          soffice
Path:             /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:       org.libreoffice.script
Version:          6.4.3002 (6.4.3002)
Parent:           launchd [1]
PID:              2014
Comment 3 Telesto 2020-05-06 10:01:57 UTC
I need a 'regular' crash.. not force quite.

Could you please try again (with initial report or this crash report)

1. Open https://bugs.documentfoundation.org/attachment.cgi?id=156698 (tdf#129524)
2. Set design-mode of the form to "yes".
3. Mark the listfield and set Anchor > To Character -> Crash (and if doesn't crash, repeat.. )
3. Press OK
Comment 4 Alex Thurgood 2020-05-07 08:01:44 UTC
(In reply to Telesto from comment #3)

> 
> 1. Open https://bugs.documentfoundation.org/attachment.cgi?id=156698
> (tdf#129524)
> 2. Set design-mode of the form to "yes".
> 3. Mark the listfield and set Anchor > To Character -> Crash (and if doesn't
> crash, repeat.. )


I can only get it to crash with "Set as character". None of the other options cause a crash.

Then I get the recovery dialog. 

If I accept the recovery procedure, the file gets "recovered", LO main Writer interface restarts, and the file is displayed minus the dropdown listbox...

If I refuse the recovery procedure, the LO main Writer interface is displayed with a new blank Writer document.
Comment 5 Telesto 2020-05-07 08:21:31 UTC
(In reply to Alex Thurgood from comment #4)

> I can only get it to crash with "Set as character". None of the other
> options cause a crash.
> 
> Then I get the recovery dialog. 
> 
> If I accept the recovery procedure, the file gets "recovered", LO main
> Writer interface restarts, and the file is displayed minus the dropdown
> listbox...

That's the point... No Apple crash reporter. I'm not exactly sure how it worked previously.. but all normal crashes go unreported this way. 

So ideally the libreoffice crash reporter appears.. or as alternative apple crash reporter.
Comment 6 Alex Thurgood 2020-05-07 08:56:52 UTC
OK, confirming then :-)
Comment 7 Telesto 2020-05-07 22:10:23 UTC
@Tor
Any clue related to MacOS crash reports?
Comment 8 Tor Lillqvist 2020-05-08 05:49:43 UTC
No.
Comment 9 Telesto 2020-05-21 07:44:43 UTC

*** This bug has been marked as a duplicate of bug 113285 ***
Comment 10 Telesto 2020-05-21 07:45:26 UTC

*** This bug has been marked as a duplicate of bug 100341 ***