Download it now!
Bug 132758 - crash swlo!SwNodeIndex::operator!=+5b7a
Summary: crash swlo!SwNodeIndex::operator!=+5b7a
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-05-06 10:34 UTC by Telesto
Modified: 2020-12-25 20:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
BT without symbols (10.95 KB, text/plain)
2020-05-06 10:34 UTC, Telesto
Details
Example file (159.68 KB, application/vnd.oasis.opendocument.text)
2020-05-06 10:35 UTC, Telesto
Details
Screencast (2.55 MB, video/mp4)
2020-05-06 11:18 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-06 10:34:42 UTC
Description:
crash swlo!SwNodeIndex::operator!=+5b7a

Steps to Reproduce:
1. Open the attached file
2. Toy around with the cat.. move it to different positions
3. Cut the image -> Crash

It's reproducible but not clear steps.. seems to have a timing component too

Inspirational screencast attached

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc:
Comment 1 Telesto 2020-05-06 10:34:57 UTC
Created attachment 160419 [details]
BT without symbols
Comment 2 Telesto 2020-05-06 10:35:11 UTC
Created attachment 160420 [details]
Example file
Comment 3 Telesto 2020-05-06 11:18:26 UTC
Created attachment 160427 [details]
Screencast
Comment 5 Telesto 2020-05-06 11:29:17 UTC
No repro with
Versie: 6.1.6.3
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: GL; 
Locale: nl-NL (nl_NL); Calc: CL

I tried pretty hard..
Comment 6 MM 2020-05-06 15:16:48 UTC
Confirmed on windows 10 x64 with Version: 6.4.4.1 (x64)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win

No crashreport, as this is not working on this version.
Comment 7 Martin Srdoš 2020-12-25 19:52:31 UTC
Hello guys,

I can't reproduce it today in master

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 1ac449874c0e93ee7e7a9765053d392fde0067f4
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: threaded

Could you please try to reproduce it with a master build from https://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongsidethe standard version.
Comment 8 Telesto 2020-12-25 20:37:30 UTC
Looks stable to me
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL