Bug 132785 - Converting word document to pdf removes bibliography
Summary: Converting word document to pdf removes bibliography
Status: RESOLVED DUPLICATE of bug 129353
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.5.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks:
 
Reported: 2020-05-06 17:05 UTC by Rhys Young
Modified: 2020-05-21 10:43 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word doc - includes bibliography (21.96 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-05-06 17:06 UTC, Rhys Young
Details
Converted pdf - no bibliography (27.88 KB, application/pdf)
2020-05-06 17:07 UTC, Rhys Young
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rhys Young 2020-05-06 17:05:58 UTC
Description:
When Converting the docx document to a pdf, it loses the bibliography.

Steps to Reproduce:
1. Convert file to PDF using 'soffice --headless --nolockcheck --nodefault --nofirststartwizard --nologo --norestore --convert-to pdf --outdir /tmp /tmp/test.docx'
2. Open PDF using a viewer
3. Observe the bibliography is gone

Actual Results:
Bibliography should be included in the converted pdf.

Expected Results:
Bibliography is not included in the converted pdf.


Reproducible: Always


User Profile Reset: No



Additional Info:
None
Comment 1 Rhys Young 2020-05-06 17:06:51 UTC
Created attachment 160464 [details]
Word doc - includes bibliography
Comment 2 Rhys Young 2020-05-06 17:07:20 UTC
Created attachment 160465 [details]
Converted pdf - no bibliography
Comment 3 Timur 2020-05-20 12:19:24 UTC
I notices you make a number of bug reports with headless, where it's not an issue. 
So first here and in all bugs please:ΕΎ
- test if headless is a problem or it's general LO 
- did you search for existing bugs before report?
Comment 4 Rhys Young 2020-05-20 12:42:28 UTC
Sorry they should be all general LO. I had been clearing out a backlog of defects from clients and was under the impression headless was a needed command. Sorry about that.

Yes, I did search for existing defects however with the giant influx of bugs in our backlog, while triaging the defects , some may have been missed as I went through a lot of defects. Again, sorry for an inconvenience that may have caused.
Comment 5 QA Administrators 2020-05-21 03:44:17 UTC Comment hidden (obsolete)
Comment 6 Timur 2020-05-21 10:40:40 UTC
Attached PDF is 4 pages. 
No repro 7.0+, 5 pages. 
Repro with 6.4 in Linux  but fixed. 
 43ef22d8789df34135fd447c007c15b93d9595c1 is the first good commit
commit 43ef22d8789df34135fd447c007c15b93d9595c1
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Jan 9 08:27:01 2020 +0100

    source e76fcb8f169acac3d81bdaf9b126cc4c98e2eb8e
Previous source 75265fad67c38827aec074e99e010109f9219079

https://gerrit.libreoffice.org/plugins/gitiles/core/+/e76fcb8f169acac3d81bdaf9b126cc4c98e2eb8e%5E!/

I'n not clear how 6.3.5.1 when this fix was in https://wiki.documentfoundation.org/Releases/6.3.5/RC1.

This report was wrong on many issues: not headless, not PDF convert but fileopen, already fixed. It's very wrong and annoying to start from "I make headless convert" which is different from objective issue. 

Rhys, you are an advanced user or IT pro. 
Please always search and test with LO master before submitting, do it now for other bugs.

*** This bug has been marked as a duplicate of bug 129353 ***