Bug 132829 - Copying to protected cells
Summary: Copying to protected cells
Status: RESOLVED DUPLICATE of bug 123974
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-07 21:57 UTC by Nuno Varela
Modified: 2020-05-08 21:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nuno Varela 2020-05-07 21:57:16 UTC
Description:
In a protected sheet, when copying some random (unprotected) cells from one row and pasting them together in another row (with protected cells), protected cells are overwritten and become unprotected with copied contents...
(sorry for my bad grammar)

Steps to Reproduce:
1.selecting random (unprotected) cells in a prtotected sheet
2.pasting them together in another row (with protected cells)
3.overwritten and become unprotected with copied contents

Actual Results:
all overwritten cells become unprotected with copied contents

Expected Results:
It should had prevented copying to protected cells giving an alert


Reproducible: Always


User Profile Reset: No



Additional Info:
Versão: 6.4.3.2 (x64)
ID da versão: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
Processos do CPU: 4; SO: Windows 10.0 Build 19041; Gestão da interface: GL; VCL: win; 
Configuração regional: pt-PT (pt_PT); Idioma da interface: pt-PT
Calc: threaded
Comment 1 m.a.riosv 2020-05-08 21:43:41 UTC

*** This bug has been marked as a duplicate of bug 123974 ***