Download it now!
Bug 132848 - request new feature of automatically adjustable guides
Summary: request new feature of automatically adjustable guides
Status: RESOLVED DUPLICATE of bug 100141
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.3.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Object-Selection-Alignment
  Show dependency treegraph
 
Reported: 2020-05-08 16:11 UTC by joalisson
Modified: 2020-05-08 17:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
reference image to add the proposed new tool (42.36 KB, application/pdf)
2020-05-08 16:23 UTC, joalisson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joalisson 2020-05-08 16:11:50 UTC
Description:
request a feature that aligns objects and text, automatically adjusting, creating reference guides.  

Steps to Reproduce:
1.automatically adjustable guides


Actual Results:
when clicking on the object, it automatically creates guide lines of adjustment, to align with other objects, applied to align objects and texts.

Expected Results:
when clicking on the object, it automatically creates guide lines of adjustment, to align with other objects, applied to align objects and texts.


Reproducible: Always


User Profile Reset: No



Additional Info:
when clicking on the object, it automatically creates guide lines of adjustment, to align with other objects, applied to align objects and texts.
Comment 1 joalisson 2020-05-08 16:23:17 UTC
Created attachment 160542 [details]
reference image to add the proposed new tool

when clicking on the object, automatically create reference lines of adjustment, to align to other objects, applied to align objects and texts.
Comment 2 V Stuart Foote 2020-05-08 17:06:22 UTC
Doesn't this already exist for both Draw and Impress? We provide a combination of the Tools -> Options -> Draw/Impress: where setting check-box for

View - 'Helplines while moving'

Grid - 'Visible grid'

Support visual layout of draw objects on page or slide.

Admittedly, we do not calculate a helpline for center of object as shown in example clip (which looks to be PowerPoint?). Nor do we expose helplines for more than one object at a time.  

But don't see that as much of an issue. Our multi-object arrange and alignment controls handle the object centers without issue, so adding a visual indicator for centering, while convenient is probably not worth the dev effort.
Comment 3 V Stuart Foote 2020-05-08 17:12:33 UTC

*** This bug has been marked as a duplicate of bug 100141 ***