Bug 132851 - UI: The image dialog has a lot of empty space
Summary: UI: The image dialog has a lot of empty space
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Area-Fill-Tab Image-Dialog
  Show dependency treegraph
 
Reported: 2020-05-08 17:30 UTC by Telesto
Modified: 2020-11-12 07:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (73.85 KB, image/jpeg)
2020-05-08 18:04 UTC, Telesto
Details
Screenshot (83.95 KB, image/jpeg)
2020-09-26 14:02 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-08 17:30:11 UTC
Description:
UI: The image dialog has a lot of empty space

Steps to Reproduce:
1. Open Writer
2. insert an image (picture)
3. Format -> Image -> Properties. Walk through all tabs.. lot of empty space

Is this caused by the Macro tab? Can it not trimmed down a little?

Actual Results:
Lots of empty space

Expected Results:
Dialog matching the content


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2020-05-08 17:34:44 UTC
Area -> Gradient tab, dammit
Comment 2 Telesto 2020-05-08 17:51:28 UTC
Me complaining a little.. 

Dialogs containing the Area tab all end up over sized for the content (lots of empty space).
Is there no way to shrink the Height of Area/Gradient tab (the other Area tabs be trimmed down pretty easy, I think). Macro window too.   

I'm in the area of border/angle sliders. Removing them.. shrink them/positioning them next to each other.. Don't think the sliders be to sensitive.. after making the shorter..  

Would - in general - be an aesthetically improvement, IMHO. Bit of a concession related to Gradient tab. But worth it.
Comment 3 Telesto 2020-05-08 18:04:35 UTC
Created attachment 160546 [details]
Screenshot
Comment 4 Heiko Tietze 2020-05-11 13:50:27 UTC
We could move the Anchor frame to the bottom. What do you think, Andreas?
Comment 5 Thomas Lendo 2020-09-25 16:37:38 UTC
I close this as Worksforme.

The attached screenshot is based on a 7.0 alpha and the dialogs have changed since that build a lot. Now there is no space in this dialog.
Comment 6 Telesto 2020-09-26 08:58:31 UTC
No change to be seen.. looks exactly the same in
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 52a49f9e480ca03e231cfda82640a928393131c9
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 7 Thomas Lendo 2020-09-26 13:47:38 UTC
Cannot reproduce with Linux nor with
Version: 7.1.0.0.alpha0+ (x64)
Build ID: abcc4eb907661e07ad850ccce7eb06f129da4286
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: de-AT (de_AT); UI: en-US
Calc: threaded

It's also not changing after using the Macro tab.

@Andreas Kainz: Can you see this issue?

@Telesto: Is this issue also there in other user profiles?
Comment 8 Telesto 2020-09-26 14:02:52 UTC
Created attachment 165868 [details]
Screenshot

FWIW: I'm talking about the area with the red arrow. 

Caused by Area Gradient such (or more general the dialog with the most content)
Comment 9 Thomas Lendo 2020-09-26 15:39:04 UTC
(In reply to Telesto from comment #8)
> FWIW: I'm talking about the area with the red arrow. 
Argh! Thanks for clarification. When this information would be available in comment 0, we would have saved a piece of my and your life time.

To this issue:
On Linux the Type tab of the image dialog looks good and not much space is in the bottom of the dialog window.

As you said, the Area fill tab with Gradient, Bitmap, Pattern and Hatch is the reason for this minimum height (I assume the Macro tab fields are flexible). Especially Gradient and (less) Bitmap would need deeper thoughts as not only the selection area on the left but also the preferences in the center of the dialog window needs much vertical space.

For me it's up to Heiko and Andreas if they can or want find a space-saving solution.

As the Area fill tab is part of many dialogs, I tend to Worksforme.
Comment 10 andreas_k 2020-09-26 16:41:02 UTC
I'm all for make the area fill tab smaller but it's very difficult at least with the 3 column workflow as it is now.
Comment 11 Xisco Faulí 2020-11-11 15:59:30 UTC
(In reply to andreas_k from comment #10)
> I'm all for make the area fill tab smaller but it's very difficult at least
> with the 3 column workflow as it is now.

Worksforme then ?
Comment 12 Telesto 2020-11-11 17:05:49 UTC
(In reply to andreas_k from comment #10)
> I'm all for make the area fill tab smaller but it's very difficult at least
> with the 3 column workflow as it is now.

Any screenshot maybe. I assume you tried. Not clear visual on this
Comment 13 QA Administrators 2020-11-12 04:54:14 UTC Comment hidden (obsolete)
Comment 14 Heiko Tietze 2020-11-12 07:36:30 UTC
LGTM on Linux, minor design issue on Windows or with gen. => NAB