Bug 132865 - UI: Image dialog as tab with similar settings as size and position for shapes but looks totally different
Summary: UI: Image dialog as tab with similar settings as size and position for shapes...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Dialog-UX
  Show dependency treegraph
 
Reported: 2020-05-08 21:43 UTC by Telesto
Modified: 2022-01-31 17:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots of image and text box property dialogs (80.46 KB, image/png)
2020-05-11 15:01 UTC, Heiko Tietze
Details
Screenshot (78.95 KB, image/jpeg)
2020-05-11 15:17 UTC, Telesto
Details
Image Type tab update (21.92 KB, image/png)
2020-05-13 12:04 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-08 21:43:09 UTC
Description:
Image dialog as tab with similar settings as size and position for shapes but looks totally different

Steps to Reproduce:
1. Open Format -> Images -> Properties -> Type tab
2. Format -> Text box & shape -> Position and size -> Position and size

Actual Results:
Comparable settings; totally different layout.. hard to orientate.

Expected Results:
Similar settings, similar layout


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Regina Henschel 2020-05-09 14:14:15 UTC
I guess, you are working in Writer.
The dialogs are different because the object types are different. The image is a com.sun.star.txt.TextGraphicObject (= FrameShape), and the shape is a com.sun.star.ddrawing.GraphicObjectShape.
Comment 2 Telesto 2020-05-09 15:05:46 UTC
(In reply to Regina Henschel from comment #1)
> I guess, you are working in Writer.
> The dialogs are different because the object types are different. The image
> is a com.sun.star.txt.TextGraphicObject (= FrameShape), and the shape is a
> com.sun.star.ddrawing.GraphicObjectShape.

It's more about the look of the look and feel of the UI. I have no issue with a different dialog.. However, the content is quite similar (my technically different, but functional mostly the same).

I have no trouble with additional different/settings etc.. But why a total different UI design.

Note: I prefer the Position and size layout.. as far as settings are matching..
Comment 3 Heiko Tietze 2020-05-11 15:01:17 UTC
Created attachment 160671 [details]
Screenshots of image and text box property dialogs

It's actually quite similar what you get. Top-left the size (shapes don't hacve the relational attributes), next to it the anchor and besides the protection it's the same.
Comment 4 Telesto 2020-05-11 15:17:13 UTC
Created attachment 160672 [details]
Screenshot
Comment 5 Telesto 2020-05-11 15:18:15 UTC
(In reply to Heiko Tietze from comment #3)
> Created attachment 160671 [details]
> Screenshots of image and text box property dialogs
> 
> It's actually quite similar what you get. Top-left the size (shapes don't
> hacve the relational attributes), next to it the anchor and besides the
> protection it's the same.

Looks indeed the same.. but not on Windows.... Position and size is the same.. but the image dialog is different
Comment 6 Heiko Tietze 2020-05-11 18:01:15 UTC
Sorry, tested with 6.3. The dialog was changed for 7.0 in https://gerrit.libreoffice.org/c/core/+/92623 without a reference to BZ. Andreas, was it done as personal preference or do have you had a good reason?
Comment 7 andreas_k 2020-05-11 21:11:26 UTC
Thanks for the bug report. Sure I should also write one before I change the property type tab for images.

However the idea behind the change was the following:
- first items first and Anchor is the first stuff you have to change than you can play around with Position and Size
- as in (all) most other dialogues the preference is to have one row per section if you compare Position before and after, it was before optimized for vertical space.

I suggest to change possition and size also to the new layout and if I forget position and size stuff somewhere else, let me know in general all position and size stuff (arrangement stuff) should have the same layout. In writer Anchor is on top, cause in writer you have to first define the anchor.

We can also define

Position
 - Horizontal -       - Vertical -
Size
   - Width -            - Height -

which we use in the sidebar. For me position and size will be one "block" so they should have the same layout everywhere.
Comment 8 Heiko Tietze 2020-05-12 06:26:33 UTC
I agree with Telesto that this white-space feels wrong. And the previous horizontal placement of "Horizontal: [from left] by [1cm] to [Paragraph]" is easier to read than the vertical alignment. At least for western languages ;-).
Comment 9 andreas_k 2020-05-12 06:32:36 UTC
As I played around with Position and Size to make Image Type tab and Shape Position Tab similar, ... it's not very easy and maybe the easies way is to revert the patch and don't update the tabs.

If someone has a better idea let me know otherwise I'll revert the image -> type tab patch.

The checkboxes are technical correct in the origin dialog but they make it very difficult to read the UI.
Comment 10 andreas_k 2020-05-12 06:45:01 UTC
patch was reverted.

https://gerrit.libreoffice.org/c/core/+/92623
Comment 11 andreas_k 2020-05-13 12:04:40 UTC
Created attachment 160753 [details]
Image Type tab update

Should I update the alignment of the Image Type tab?
Comment 12 Telesto 2020-05-13 17:14:36 UTC
Looks certainly better :-)
Comment 13 sdc.blanco 2020-10-10 14:32:28 UTC
(In reply to andreas_k from comment #7)
> Thanks for the bug report. Sure I should also write one before I change the
> property type tab for images.
And if changes are made that require documentation changes (e.g., new label names, new organisation of controls), then please also make a bug report for documentation.
Comment 14 Heiko Tietze 2020-10-12 09:27:23 UTC
(In reply to andreas_k from comment #10)
> patch was reverted.

Why?
Comment 15 Heiko Tietze 2022-01-31 17:04:27 UTC
This ticket has not received comments in years, claims to be fixed and reverted, and the OP says "Looks certainly better". Resolving WFM.